xml-commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 47671] unable to resolve a relative path
Date Tue, 11 Aug 2009 04:53:37 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=47671



--- Comment #2 from Dave Pawson <dave.pawson@gmail.com> 2009-08-10 21:53:34 PDT ---
What is the full catalog?
Does the path "/files/erlang/dtds/erlref.dtd" exist on
the filesystem?  Or have you set xml:base?

Have you tried setting the verbosity with the
xml.catalog.verbosity property. Set to 5 or larger to get maximum
verbosity.  This will determine if your catalog is actually getting
read and what the resolver does when resolving a uri.

What is the exact error message(s) you get?

If you can provide a reproducable test case, it will make
finding a solution faster.

1. full catalog

<?xml version="1.0" encoding="utf-8"?>
<catalog xmlns="urn:oasis:names:tc:entity:xmlns:xml:catalog"
     >
 <system
      systemId="erlref.dtd"
      uri="/files/erlang/dtds/erlref.dtd"            />
 <systemSuffix
      systemIdSuffix="xhtml-lat1.ent"
      uri="/files/erlang/dtds/xhtml-lat1.ent"     />
</catalog>

2. The dtd and entity file are in ./dtds /files/erlang/dtds
3. I had tried xml:base, but now removed.

Instance has 
<?xml version="1.0" encoding="latin1" ?>
<!DOCTYPE erlref SYSTEM "erlref.dtd">
a file of 
<erlref>&nbsp</erlref>

would test it.

I have CatalogManger.properties with verbosity set high.

Error reported is:

Parse catalog: erlang.catalog.xml                            
Loading catalog: erlang.catalog.xml
Default BASE: file:////files/erlang/erlang.catalog.xml
system: erlref.dtd
        /files/erlang/dtds/erlref.dtd
SYSTEM: erlref.dtd
        file:/files/erlang/dtds/erlref.dtd
systemSuffix: xhtml-lat1.ent
        /files/erlang/dtds/xhtml-lat1.ent
SYSTEM_SUFFIX: xhtml-lat1.ent
        file:/files/erlang/dtds/xhtml-lat1.ent
resolveSystem(file:/files/erlang/module.xsl)
resolveSystem(file:/files/erlang/erlang.xml)
resolveSystem(file:/files/erlang/erlref.dtd)
Error on line 2 column 37 of file:/files/erlang/erlang.xml:
  Error reported by XML parser: Cannot read from file:/files/erlang/erlref.dtd
(/files/erlang/erlref.dtd (No such file or directory))
Transformation failed: Run-time errors were reported

HTH

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

Mime
View raw message