xml-commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremias Maerki <...@jeremias-maerki.ch>
Subject Re: Updating DOM to Level 3 Events?
Date Sat, 04 Feb 2006 09:36:14 GMT
Ok, that makes sense. So I'll create a new branch and put my changes
there. We can switch the trunk whenever we want later.

BTW, here's an answer to my original post by Robin Berjon. He authorized
me to forward his answer to the list. It contains interesting
information about the DOM Level 3 Events:

On 30.01.2006 00:39:08 Robin Berjon <robin.berjon@expway.fr> wrote:
> [I'm roaming so that the lists are not accepting my email]
> 
> On Jan 30, 2006, at 03:55, Jeremias Maerki wrote:
> > Currently, the Events package seems to be on DOM Level 2 but Batik  
> > requires
> > DOM Level 3 [2]. So the question is whether there's any problem if I
> > upgrade the Events package to Level 3?
> 
> How stable do you need it to be? DOM 3 Events was parked as a Note  
> after the DOM WG was disbanded. The Web APIs WG has now taken it over  
> and is driving it to Recommendation. We have a few issues with the  
> draft that need to be addressed. We don't expect to make truly  
> drastic changes, but in one case we may add an exception where none  
> and we may add a tiny amount of features. The rest is expected to  
> remain stable (many other specifications already rely on it — I'd  
> call it stable were it not that unfortunately Java has checked  
> exceptions).
> 
> -- 
> Robin Berjon
>     Senior Research Scientist
>     Expway, http://expway.com/


On 02.02.2006 16:49:34 Michael Glavassevich wrote:
> Jeremias Maerki <dev@jeremias-maerki.ch> wrote on 01/29/2006 11:55:09 AM:
> 
> > (cc'ing batik-dev)
> > 
> > I've finally found time to implement the plan [1] to add the SAC, SMIL
> > and SVG DOM Java Bindings to XML Commons External. Everything's ready to
> > be committed but I'm holding back for the moment since an unexpected
> > detail came up:
> > 
> > Currently, the Events package seems to be on DOM Level 2 but Batik 
> requires
> > DOM Level 3 [2]. So the question is whether there's any problem if I
> > upgrade the Events package to Level 3?
> >
> > I can see that JAXP 1.3 seems to be on Level 2 still: see [3]. Any
> > feedback and suggestions how to proceed would be appreciated.
> 
> TCKs tend to have signature tests which verify that the classes/interfaces 
> defined or endorsed by the spec are precisely what was specified. I see 
> that DOM Level 3 events adds methods to existing interfaces, so I'd say 
> there's a good chance such a move would cause a TCK failure. We probably 
> need a branch for this (or create a JAXP 1.3 TCK compliant branch).
>  
> > [1] http://mail-archives.apache.org/mod_mbox/xml-commons-dev/200506.
> > mbox/%3c20050626133157.488E.DEV.JEREMIAS@greenmail.ch%3e
> > [2] http://www.w3.org/TR/2003/NOTE-DOM-Level-3-Events-20031107/java-
> > binding.html
> > [3] http://java.sun.com/j2se/1.5.
> > 0/docs/api/org/w3c/dom/events/package-summary.html
> > 
> > Jeremias Maerki


Jeremias Maerki


Mime
View raw message