xml-commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 34836] New: - Xalan 1.9 crashes when initializing
Date Tue, 10 May 2005 11:17:38 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=34836>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=34836

           Summary: Xalan 1.9 crashes when initializing
           Product: XmlCommons
           Version: 1.x
          Platform: Other
        OS/Version: Windows XP
            Status: NEW
          Keywords: ErrorMessage
          Severity: normal
          Priority: P2
         Component: DOM
        AssignedTo: commons-dev@xml.apache.org
        ReportedBy: marcvila9@hotmail.com


Hi All,
After downloading and compiling successfully Xerces 2.6 and Xalan 1.9, I got 
into problems when I try to use Xalan.
I just call:

XMLPlatformUtils::Initialize();
XalanTransformer::initialize();

and the second instruction crashes when calls DoubleSupport::initialize() 
function (the assignment s_NaN.d = sqrt(-2.01); causes a Unhandled exception: 
Floating-point invalid operation.)

I was using Xerces 2.5 with Xalan 1.8 without problems, and it was when I 
updated my code to 2.6 ans 1.9 when I got this problem.

Any idea? Am i doing something wrong?
I am compiling under Visual Studio .NET.
Thanks in advance,
Marc.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

Mime
View raw message