xml-commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eduardo Pelegri-Llopart <Eduardo.Pelegrillop...@Sun.COM>
Subject Re: Donation of JAXP 1.3 Sources to Apache
Date Tue, 12 Oct 2004 16:36:28 GMT
The bottom line for the APIs is "yes for this case, but don't assume it 
will necessarily continue to be so".  For our specific implementation, 
it certainly works for J2SE 1.4, but don't know about 1.3 and below.


Some more details on the API situation. JAXP is bundled in J2SE and in 
J2EE.  There are rules in the platforms that keep versions of their 
specs in sync, so that developers know what they are getting.  Now, JAXP 
1.3 is in J2SE 1.5, JAXP 1.1 is in J2SE 1.4, but there is no JAXP in 
J2SE 1.3.  So the rules say that JAXP 1.3 can be used in J2SE 1.5 
(duh!), and in J2SE 1.3 and lesser J2SEs, but not in j2SE 1.4.

The rules exist for a reason, but in this case, we (Sun) recognized that 
the disadvantages of this would seem to outweight the benefits, so some 
time ago I requested and received from the J2SE group permision to 
change the rules for this particular release.  This means it is legal 
for JAXP 1.3 to be used with J2SE 1.4 too.

Moving forward, though, I would not expect the exception to the rule to 
be continued as the penalty is too heavy.  For example, I expect JAXP 
1.4 to take want to advantage of features in Tiger and Mustang.  That is 
a different discussion but I didn't want to mislead you.

Hope this helps,

	- eduard/o

Elliotte Harold wrote:

> Are these APIs and implementation thereof independent of Java 1.5? i.e. 
> can they be compiled and used in a Java 1.2/1.3/1.4 environment? If not, 
> could they be backported to work in such environments?
> 

Mime
View raw message