xml-commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From shane_curc...@us.ibm.com
Subject Re: org.xml.sax.helpers.DefaultHandler in xml-commons/JAXP
Date Tue, 21 Oct 2003 19:11:40 GMT
Grrrr.  Trying to handle too many different standards at once is a 
headache, I agree.

In principle I'd say we'll be shipping the version that matches the 
current JAXP 1.2 TCK, since we need to pass the TCK to have an official 
release.  Unfortunately this sometimes means shipping potentially 
confusing code for those who are already expecting the latest-and-greatest 
of all their components.  I'm at least also relying on some other 
volunteers to actually run the TCK tests since I don't have them on my 
machine.

And the BUGS-sax file was just me checking in the entire SAX distribution 
as-is a long time ago; it probably hasn't been updated by anyone since 
then for bugfixes or for SAX/JAXP version updates.  Sorry!

Does that help at all?  I'm too tired today to completely parse the 
message, but does anyone believe that we still have SAX code that does not 
match the JAXP 1.2 TCK?  If so, we need to fix it.  If we have code that 
does not match sourceforge SAX release, well, then, that's too bad for 
now.  (Note: we plan to ship from the tck-jaxp-1_2_0 branch - if someone 
else has a proposal to change things on the HEAD, that's fine; we just 
can't have official releases from there until the JAXP TCK's get updated).

- Shane

Mime
View raw message