xml-commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shane_Curc...@lotus.com
Subject xml-commons related bug: [Bug 2291] New: - Reading "META-INF/services/" should NOT assume default character encoding is UTF-8
Date Fri, 22 Jun 2001 23:16:41 GMT
Could one of you two evaluate this and apply it to xml-commons at your
leisure?  I think this is a no-brainer to stick into Xalan this weekend
(Scott is going to apply it there).  Am I missing something, or is this a
pretty obvious bug and an easy fix for other platforms?

Any quick analysis you have this weekend would be very useful for me;
fixing this in xml-commons can be whenever.  We're on an internal release
for the next week and a half, after that I'll come back and jump-start the
xml-commons work (I have ideas for overall standards, builds, and
integration proposals I just need to type and checkin...)

Thanks,
Shane

P.S. Hey, do you two even work together at all, or am I just chatting to
two people from completely different areas?  (It's so wierd knowing all
these 'individual' committers separately and trying to figure out who knows
who else - even when they work at the same company!)

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=2291

*** shadow/2291           Fri Jun 22 12:06:11 2001
--- shadow/2291.tmp.21617           Fri Jun 22 12:06:11 2001
***************
*** 0 ****
--- 1,33 ----
+
+============================================================================+

+ | Reading "META-INF/services/" should NOT assume default character
encoding  |
+
+----------------------------------------------------------------------------+

+ |        Bug #: 2291                        Product: XalanJ2
|
+ |       Status: NEW                         Version: 2.0.x
|
+ |   Resolution:                            Platform: All
|
+ |     Severity: Major                    OS/Version: Other
|
+ |     Priority: Other                     Component: javax.xml
|
+
+----------------------------------------------------------------------------+

+ |  Assigned To: xalan-dev@xml.apache.org
|
+ |  Reported By: alex.cameron@royalbank.com
|
+ |      CC list: Cc:
|
+
+----------------------------------------------------------------------------+

+ |          URL:
|
+
+============================================================================+

+ |                              DESCRIPTION
|
+ I installed Xalan-J_2_1_0 on an OS/390 V2.10 system. The following
classes
+ assume that the default character encoding of the executing system is
UTF-8.
+
+ ./javax/xml/parsers/DocumentBuilderFactory.java
+ ./javax/xml/parsers/SAXParserFactory.java
+ ./javax/xml/transform/TransformerFactory.java
+
+ This is not true on systems like OS/390 V2.10. To fix these classes,
change the
+ code to read:
+
+ BufferedReader rd =new BufferedReader(new InputStreamReader(is,"UTF-8"));
+
+ instead of:
+
+ BufferedReader rd =new BufferedReader(new InputStreamReader(is));
+
+ Or, they will not be able to correctly read META-INF/services/
\ No newline at end of file






Mime
View raw message