xerces-p-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pluta, Edward" <Edward_Pl...@csgsystems.com>
Subject RE: Errors building xerces on AIX
Date Fri, 28 Jul 2006 14:09:35 GMT
What we did was to change the Makefile.incl to basically have the save
options as a linux compile. I have attached our version of the
Makefile.incl (not sure if it will come through or not). The only
section that I believe we changed was the AIX options now has an IF for
gcc, other wise it does what it did before. We used gcc 4.1.1 on AIX
5.2, but it should work for you as well.
 
I was going to forward this to the development staff at one point but
could not figure out where to send it. Does anyone know?
 
Good luck.

________________________________

From: Sandeep Shahane [mailto:Sandeep_Shahane@symantec.com] 
Sent: Friday, July 28, 2006 8:58 AM
To: p-dev@xerces.apache.org
Subject: Errors building xerces on AIX


Hi, 
    I am building xerces library on AIX (4.3.3, but later plan to also
build on 5.x versions) with runconfigure options as ./runConfigure -p
aix -c gcc -x g++ -d -C "--prefix=/usr/local/xerces". (I do not have
native AIX compiler.)
 
After building all .o files it gives error makeC++SharedLib not found. I
searched over the web for this error, and seems like it still uses
native xcl compiler that I dont have. So, now I want to override it with
equivalent g++ options. What do I need to do (is only changes
Makefile.incl sufficient, or did I miss anything else) ? 
 
What are the appropriate g++ options that I need to specify 'coz the
options that i tried as below still gives errors
 
g++ -DAIX -shared -fPIC  -Wl,-soname,libxerces-c.so -o
/home/mpai/xerces/xerces-c-src_2_7_0/lib/libxerces-c.so
 
I tried modifying Makefile.incl in AIX section to make shared lib with
g++ -v --shared ${LDFLAGS} options that also didn't work.

Thanks and Regards,
Sandeep

 

Mime
View raw message