xerces-p-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sandeep Shahane" <Sandeep_Shah...@symantec.com>
Subject RE: Errors building xerces on AIX
Date Fri, 28 Jul 2006 14:08:12 GMT
>>I tried modifying Makefile.incl in AIX section to make shared lib with
g++ -v --shared ${LDFLAGS} options that also didn't work.
Error that I am getting after doing this is as follows:
 
Thread model: aix
gcc version 3.3.5
 /usr/local/gcc-3.3.5/lib/gcc-lib/powerpc-ibm-aix4.3.3.0/3.3.5/collect2
-bpT:0x10000000 -bpD:0x20000000 -btextro -bnodelcsect -bM:SRE -bnoentry
-o /home/mpai/xerces/xerces-c-src_2_7_0/lib/libxerces-depdom27.0.a
-L/usr/lpp/xlC/lib -L/home/mpai/xerces/xerces-c-src_2_7_0/lib
-L/usr/local/gcc-3.3.5/lib/gcc-lib/powerpc-ibm-aix4.3.3.0/3.3.5
-L/usr/local/gcc-3.3.5/lib/gcc-lib/powerpc-ibm-aix4.3.3.0/3.3.5/../../..
AIX/depdom/AttrImpl.o AIX/depdom/AttrMapImpl.o AIX/depdom/AttrNSImpl.o
AIX/depdom/CDATASectionImpl.o AIX/depdom/CharacterDataImpl.o
AIX/depdom/ChildNode.o AIX/depdom/CommentImpl.o AIX/depdom/DOMParser.o
AIX/depdom/DOMString.o AIX/depdom/DOM_Attr.o
AIX/depdom/DOM_CDATASection.o AIX/depdom/DOM_CharacterData.o
AIX/depdom/DOM_Comment.o AIX/depdom/DOM_DOMException.o
AIX/depdom/DOM_DOMImplementation.o AIX/depdom/DOM_Document.o
AIX/depdom/DOM_DocumentFragment.o AIX/depdom/DOM_DocumentType.o
AIX/depdom/DOM_Element.o AIX/depdom/DOM_Entity.o
AIX/depdom/DOM_EntityReference.o AIX/depdom/DOM_NamedNodeMap.o
AIX/depdom/DOM_Node.o AIX/depdom/DOM_NodeFilter.o
AIX/depdom/DOM_NodeIterator.o AIX/depdom/DOM_NodeList.o
AIX/depdom/DOM_Notation.o AIX/depdom/DOM_ProcessingInstruction.o
AIX/depdom/DOM_Range.o AIX/depdom/DOM_RangeException.o
AIX/depdom/DOM_Text.o AIX/depdom/DOM_TreeWalker.o
AIX/depdom/DOM_XMLDecl.o AIX/depdom/DStringPool.o
AIX/depdom/DeepNodeListImpl.o AIX/depdom/DocumentFragmentImpl.o
AIX/depdom/DocumentImpl.o AIX/depdom/DocumentTypeImpl.o
AIX/depdom/DomMemDebug.o AIX/depdom/ElementDefinitionImpl.o
AIX/depdom/ElementImpl.o AIX/depdom/ElementNSImpl.o
AIX/depdom/EntityImpl.o AIX/depdom/EntityReferenceImpl.o
AIX/depdom/NamedNodeMapImpl.o AIX/depdom/NodeIDMap.o
AIX/depdom/NodeImpl.o AIX/depdom/NodeIteratorImpl.o
AIX/depdom/NodeListImpl.o AIX/depdom/NodeVector.o
AIX/depdom/NotationImpl.o AIX/depdom/ParentNode.o
AIX/depdom/ProcessingInstructionImpl.o AIX/depdom/RangeImpl.o
AIX/depdom/RefCountedImpl.o AIX/depdom/TextImpl.o
AIX/depdom/TreeWalkerImpl.o AIX/depdom/XMLDeclImpl.o -lpthreads_compat
-lxerces-c -lstdc++ -lm -lgcc_s -lc -lgcc_s
collect2: library libxerces-c not found
make[1]: ***
[/home/mpai/xerces/xerces-c-src_2_7_0/lib/libxerces-depdom27.0.a] Error
1
make[1]: Target `ALL' not remade because of errors.
make[1]: Leaving directory `/home/mpai/xerces/xerces-c-src_2_7_0/obj'
make: *** [/home/mpai/xerces/xerces-c-src_2_7_0/lib/libxerces-c27.0.a]
Error 2

 

Thanks and Regards,
Sandeep

 

________________________________

From: Sandeep Shahane 
Sent: Friday, July 28, 2006 7:28 PM
To: 'p-dev@xerces.apache.org'
Subject: Errors building xerces on AIX


Hi, 
    I am building xerces library on AIX (4.3.3, but later plan to also
build on 5.x versions) with runconfigure options as ./runConfigure -p
aix -c gcc -x g++ -d -C "--prefix=/usr/local/xerces". (I do not have
native AIX compiler.)
 
After building all .o files it gives error makeC++SharedLib not found. I
searched over the web for this error, and seems like it still uses
native xcl compiler that I dont have. So, now I want to override it with
equivalent g++ options. What do I need to do (is only changes
Makefile.incl sufficient, or did I miss anything else) ? 
 
What are the appropriate g++ options that I need to specify 'coz the
options that i tried as below still gives errors
 
g++ -DAIX -shared -fPIC  -Wl,-soname,libxerces-c.so -o
/home/mpai/xerces/xerces-c-src_2_7_0/lib/libxerces-c.so
 
I tried modifying Makefile.incl in AIX section to make shared lib with
g++ -v --shared ${LDFLAGS} options that also didn't work.

Thanks and Regards,
Sandeep

 

Mime
View raw message