xerces-p-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sandeep Shahane" <Sandeep_Shah...@symantec.com>
Subject Errors building xerces on AIX
Date Fri, 28 Jul 2006 13:58:02 GMT
Hi, 
    I am building xerces library on AIX (4.3.3, but later plan to also
build on 5.x versions) with runconfigure options as ./runConfigure -p
aix -c gcc -x g++ -d -C "--prefix=/usr/local/xerces". (I do not have
native AIX compiler.)
 
After building all .o files it gives error makeC++SharedLib not found. I
searched over the web for this error, and seems like it still uses
native xcl compiler that I dont have. So, now I want to override it with
equivalent g++ options. What do I need to do (is only changes
Makefile.incl sufficient, or did I miss anything else) ? 
 
What are the appropriate g++ options that I need to specify 'coz the
options that i tried as below still gives errors
 
g++ -DAIX -shared -fPIC  -Wl,-soname,libxerces-c.so -o
/home/mpai/xerces/xerces-c-src_2_7_0/lib/libxerces-c.so
 
I tried modifying Makefile.incl in AIX section to make shared lib with
g++ -v --shared ${LDFLAGS} options that also didn't work.

Thanks and Regards,
Sandeep

 

Mime
View raw message