xerces-p-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ja...@openinformatics.com (Jason E. Stewart)
Subject Re: Similar make test error
Date Sat, 11 Oct 2003 06:18:46 GMT
Steve Mathias <smathias@unm.edu> writes:

> I am getting similar errors on 'make test' to what was reported earlier
> by Kai.  For me, every single test fails with the message:
> 
> Can't load '/usr/local/src/perl/XML-Xerces-2.3.0-1/blib/arch/auto/XML/Xerces/Xerces.so'
for module XML::Xerces: /usr/local/src/perl/XML-Xerces-2.3.0-1/blib/arch/auto/XML/Xerces/Xerces.so:
undefined symbol: isAnySlash__Q211xercesc_2_316XMLPlatformUtilsUs at /usr/local/lib/perl5/5.6.1/i686-linux/DynaLoader.pm
line 206.
>  at /usr/local/src/perl/XML-Xerces-2.3.0-1/blib/lib/XML/Xerces.pm line 7
> 
> I'm using xerces-c version 2_3_0 which I built myself with gcc version
> 2.96 (I've tried a couple of the samples and they run fine) and xerces-p
> version 2.3.0-1.

I don't have gcc-2.96 to test this on, but I don't think the gcc
version is the issue here.

I'm assuming that you've tried to run DOMCount or some other Xerces-C
application just to ensure the libxerces.so is working fine?

If so then please grep the library symbols using the commands I sent
to Kai, and lets see what's happenging there.

Cheers,
jas.

PS. It's funny that your from UNM. Up until three months ago I lived
at San Pedro and Zuni in sunny ABQ - but then I moved to India!

---------------------------------------------------------------------
To unsubscribe, e-mail: xerces-p-dev-unsubscribe@xml.apache.org
For additional commands, e-mail: xerces-p-dev-help@xml.apache.org


Mime
View raw message