xerces-p-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ja...@openinformatics.com (Jason E. Stewart)
Subject Re: Xerces-Perl make test gives errors
Date Fri, 10 Oct 2003 03:25:26 GMT
Kai Zimmer <zimmer@bbaw.de> writes:

> i have trouble installing Xerces-Perl. I compiled Xerces-C by myself
> (and tested the installation with DOMCount), 

Thanks for the test, that's helpful.

> but now the Xerces-Perl gives error-messages when I "make test":
> 
> Can't load '/blib/arch/auto/XML/Xerces/Xerces.so' for module
> XML::Xerces: /blib/arch/auto/XML/Xerces/Xerces.so: undefined symbol:
> _ZN11xercesc_2_316XMLPlatformUtils10isAnySlashEt at
> 
> xerces-c: xerces-c-src_2_3_0
> xerces-p: XML-Xerces-2.3.0-1

Thanks also for following the README and using identical versions.

> uname -a  (SuSE 8.2)
> Linux kira 2.4.20-64GB-SMP #1 SMP Mon Mar 17 17:56:03 UTC 2003 i686
> unknown unknown GNU/Linux

I'm surprised by this being a Linux box. I received a lot of reports
of this problem, but they were all on Mac OS X. The fix there was to
make the XMLPlatformUtils::isAnySlash() method non-inline. For some
reason being inline was screwing things up.

It's in src/xercesc/util/Platforms/Linux/LinuxPlatformUtils.cpp line
527.

Let me know if this helps and I'll send a bug report to the Xerces-C
folks. 

Cheers,
jas.

---------------------------------------------------------------------
To unsubscribe, e-mail: xerces-p-dev-unsubscribe@xml.apache.org
For additional commands, e-mail: xerces-p-dev-help@xml.apache.org


Mime
View raw message