xerces-j-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Natarajan Ravi" <Ravi.Natara...@cfh.nhs.uk>
Subject FW: Validation error in xerces -j 2.6.2 and 2.7.0 for schema types xsd:anyURI
Date Tue, 05 Jul 2005 11:36:07 GMT
I trying to validate a simple xml file against a given schema. The xml
file and the schema are shown below. Both xerces 2.6.2 and 2.7.0 are
report that the xml file is valid against the schema. where as 2.5.0
reports errors on the invalid uri value marked bold.
 
<?xml version="1.0" encoding="UTF-8"?>

<Sample xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:noNamespaceSchemaLocation="C:\Download\Test\Sample.xsd">

<tel value="fax:123%20124"/>

<tel value="tel:123 124"/>

<tel value="tel:123%20124"/>

<tel value="tel:123124%2012312"/>

</Sample>

 

<?xml version="1.0" encoding="UTF-8"?>

<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema"
elementFormDefault="qualified" attributeFormDefault="unqualified">

<xs:element name="Sample" type="ElementType">

<xs:annotation>

<xs:documentation>Comment describing your root
element</xs:documentation>

</xs:annotation>

</xs:element>

<xs:complexType name="ElementType">

<xs:sequence>

<xs:element name="tel" type="TelType" maxOccurs="unbounded"/>

</xs:sequence>

</xs:complexType>

<xs:complexType name="TelType">

<xs:attribute name="value" type="xs:anyURI"/>

</xs:complexType>

</xs:schema>

    It looks like that the latest versions of xerces are having problems
in validating xsd:anyURI types. 

 


This e-mail is confidential and privileged. If you are not the intended recipient please accept
our apologies; please do not disclose, copy or distribute information in this e-mail or take
any action in reliance on its contents: to do so is strictly prohibited and may be unlawful.
Please inform us that this message has gone astray before deleting it. Thank you for your
co-operation.



Mime
View raw message