xerces-j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 18789] - VersionNotSupported error raised while parsing an XML1.1 document with an external entity with version=1.0 in its textDecl
Date Tue, 08 Apr 2003 14:14:07 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18789>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18789

VersionNotSupported error raised while parsing an XML1.1 document with an external entity
with version=1.0 in its textDecl





------- Additional Comments From mrglavas@ece.uwaterloo.ca  2003-04-08 14:14 -------
What if?

test.xml:
<?xml version='1.1'?>
<!DOCTYPE doc SYSTEM "test.dtd">
<doc>&e;</doc>

test.dtd:
<?xml version='1.0' encoding='UTF-8'?>
<!ELEMENT doc ANY>
<!ENTITY e SYSTEM "test.ent">

test.ent:
<?xml version='1.1' encoding='UTF-8'?>
blah

According to http://www.w3.org/TR/xml11/#sec4.3.4, can test.dtd which is a 1.0 
entity, refer to a 1.1 entity? Is this illegal?

---------------------------------------------------------------------
To unsubscribe, e-mail: xerces-j-dev-unsubscribe@xml.apache.org
For additional commands, e-mail: xerces-j-dev-help@xml.apache.org


Mime
View raw message