xerces-j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From gopal sharma <gopal.sha...@Sun.COM>
Subject Re: Xerces 2.0.0 beta 4 causes Xalan to glitch
Date Wed, 09 Jan 2002 13:25:00 GMT
 Joseph Kesselman wrote :-,
 
 You were correct, while running the smoketest of Xalan with
 PARSER_JAR value set to xercesImpl.jar. It fails with the
 error:

<----Error message ----> 

 Xalan-J 2.x Build
 -------------
 Starting Ant with targets: smoketest-run
        ...with classpath:  

./bin/ant.jar:/home/xyz/Xerces/x2b4/build/xercesImpl.jar:/home/xyz/j2sdk1_3_1/lib/tools.jar
 Buildfile: build.xml

 BUILD FAILED

 No JAXP compliant XML parser found. Please visit http://xml.apache.org
for a 
 suitable parser

 Total time: 0 seconds

<----End of Error message ---->
 
 My understanding is Ant dynamically loads
*javax.xml.parsers.SAXParserFactory*
 (hardcoded in Ant) which is not available with xercesImpl.jar. So one
 either need to set xmlParserAPIs.jar or xml-apis.jar in PARSER_JAR
which solves 
 the problem.
 
 While the discussion on whether we need only one XML API jar (like
xml-apis.jar or
 xmlParserAPIs.jar) or multiple (both) on xml.apache.org should be left
to the project(s)
 only, if we don't seem to reach to a conclusion. While I am always in
favour of only one jar 
 (common) file either you call xml-apis.jar (by Xalan) or
xmlParserAPIs.jar (by Xerces). 
 But for sure, either of the jar file should have all Standard API's
required for any 
 project.

 Cheers
 
 Gopal
 ----------------------
 SUN Microsytems, India

---------------------------------------------------------------------
To unsubscribe, e-mail: xerces-j-dev-unsubscribe@xml.apache.org
For additional commands, e-mail: xerces-j-dev-help@xml.apache.org


Mime
View raw message