xerces-c-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Smith" <mrs...@gmail.com>
Subject Re: Unresolved symbol on HP-UX 11.11
Date Tue, 15 Jul 2008 06:41:47 GMT
Hi Boris,

Boris Kolpackov <boris@codesynthesis.com> wrote:
> If that's the exact command line then there is a whole bunch of
> object files missing for some reason (i.e., the library is empty).

You're right. Since the xercesc makefile hides the executed command i
generated the output with 'gmake --dry-run'. Now i removed the '-s'
options from the makefile to get the correct output and the object
files are there:

g++ -DHPUX -fPIC -shared  -Wl,+h,libxerces-c.sl.28 -o
/home/afbuild/tmpch/xerces-c-src_2_8_0/lib/libxerces-c.sl.28.0
HPUX/ASCIIRangeFactory.o HPUX/AbstractDOMParser.o
HPUX/AbstractNumericFacetValidator.o HPUX/AbstractNumericValidator.o
HPUX/AbstractStringValidator.o HPUX/AllContentModel.o
HPUX/AnySimpleTypeDatatypeValidator.o [...] -lpthread -lnsl -L/usr/lib
-L/usr/local/lib

> Did you set XERCESCROOT variable before running runConfigure and
> gmake? Your build step should look as follows:

I defined XERCESCROOT. My buil steps lokk as follows:
% tar xvf xerces-c-src_2_8_0.tar
% setenv XERCESCROOT /home/afbuild/tmpch/xerces-c-src_2_8_0
% cd /home/afbuild/tmpch/xerces-c-src_2_8_0/src/xercesc/
% ./runConfigure -p hp-11 -c gcc -x g++
% gmake > /home/afbuild/tmpch/gmake.log
% cd ../../samples/
% ./runConfigure -p hp-11 -c gcc -x g++
% gmake

When executing ./DOMCount i still get the same error:
/usr/lib/dld.sl: Unresolved symbol:
_ZNK11xercesc_2_813XMLBigDecimal10getRawDataEv (data)  from
/home/afbuild/tmpch/xerces-c-src_2_8_0/lib/libxerces-c.sl.28
Abort (core dumped)

According to 'odump' the missing symbol should be preset in libxerces-c.sl.28:
% odump -slexportlist
/home/afbuild/tmpch/xerces-c-src_2_8_0/lib/libxerces-c.sl.28 | grep
_ZNK11xercesc_2_813XMLBigDecimal10getRawDataEv
000010863 000009179  00262 0x00515478  Code  000000,155  00
_ZNK11xercesc_2_813XMLBigDecimal10getRawDataEv
000016061 000010931  -0001 0x40020c68  Plab  000000,155  00
_ZNK11xercesc_2_813XMLBigDecimal10getRawDataEv

Thanks advance for your help

John

Mime
View raw message