xerces-c-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Smith" <mrs...@gmail.com>
Subject Re: Unresolved symbol on HP-UX 11.11
Date Wed, 09 Jul 2008 06:30:14 GMT
Hi Boris,

Boris Kolpackov <boris@codesynthesis.com> writes:

> Actually, you build Xerces-C++ with HP aCC -- that's the default
> compiler on HP-UX. And that's the reason why you get symbol errors
> in your application. To build Xerces-C++ with gcc, you will need to
> configure it like this:
>
> $ ./runConfigure -p hp-11 -c gcc -x g++

I tried to build Xerces-C++ configuring it with "./runConfigure -p
hp-11 -c gcc -x g++" but i get exactly the same error as above:

/usr/lib/dld.sl: Unresolved symbol:
_ZNK11xercesc_2_813XMLBigDecimal10getRawDataEv (data)  from
/home/afbuild/tmpch/xerces-c-src_2_8_0/lib/libxerces-c.sl.28
Abort (core dumped)

When configuring Xerces-C++ with "% ./runConfigure -php-11" g++ is
used on my system:
...
g++ -DHPUX -D_REENTRANT -fPIC -c
-I/home/afbuild/tmpch/xerces-c-src_2_8_0/include
-I/home/afbuild/tmpch/xerces-c-src_2_8_0/src -w -O -DNDEBUG
-DPROJ_XMLPARSER  -DPROJ_XMLUTIL  -DPROJ_PARSERS  -DPROJ_SAX4C
-DPROJ_SAX2  -DPROJ_DOM -DPROJ_DEPRECATED_DOM -DPROJ_VALIDATORS
-DXML_USE_NATIVE_TRANSCODER -DXML_USE_INMEM_MESSAGELOADER
-DXML_USE_PTHREADS -DXML_USE_NETACCESSOR_SOCKET     -o
/home/afbuild/tmpch/xerces-c-src_2_8_0/obj/HPUX/XPathSymbols.o
XPathSymbols.cpp
echo toplevel Building
/home/afbuild/tmpch/xerces-c-src_2_8_0/lib/libxerces-c.sl.28.0
gmake -C /home/afbuild/tmpch/xerces-c-src_2_8_0/obj -k
gmake[1]: Entering directory `/home/afbuild/tmpch/xerces-c-src_2_8_0/obj'
echo Building /home/afbuild/tmpch/xerces-c-src_2_8_0/lib/libxerces-c.sl.28.0
g++ -DHPUX -fPIC -shared  -Wl,+h,libxerces-c.sl.28 -o
/home/afbuild/tmpch/xerces-c-src_2_8_0/lib/libxerces-c.sl.28.0
-lpthread -lnsl -L/usr/lib -L/usr/local/lib
...

Any other ideas?

Thanks

John

Mime
View raw message