xerces-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Boris Kolpackov (JIRA)" <xerces-c-...@xml.apache.org>
Subject [jira] Closed: (XERCESC-1297) XercesDomParser::parse() fails with StdInInputSource
Date Tue, 03 Nov 2009 06:40:59 GMT

     [ https://issues.apache.org/jira/browse/XERCESC-1297?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Boris Kolpackov closed XERCESC-1297.

    Resolution: Invalid

Seems to be application problem.

> XercesDomParser::parse() fails with StdInInputSource
> ----------------------------------------------------
>                 Key: XERCESC-1297
>                 URL: https://issues.apache.org/jira/browse/XERCESC-1297
>             Project: Xerces-C++
>          Issue Type: Bug
>          Components: DOM
>    Affects Versions: 2.6.0
>         Environment: RHAS 3.0, with gcc 3.2.3. Windows 2000, 32-bit, with MSVC7.1
>            Reporter: Aditya Kulkarni
> I am passing an instance of StdInInputSource to XercesDomParser::parse() method. An xml
file (say a.xml), is piped as input to my test program (say test). The parse method does not
throw any exception, but when I find the error count using getErrorCount() method, I get lots
of error counts, which indicates parse failure. I am catching all exceptions which the parse
method throws.
> There are two cases that I would like to discuss.
> [1] contents of xml file are piped in: 
>     program invocation on RHAS 3.0: cat a.xml | ./test 
>     In this case, an instance of StdInInputSource is created, and is passed to the XercesDomParser::parse()
>     Result: parse failure, as indicated by error counts
> [2] name of xml file is given on command line:
>     program invocation on RHAS 3.0: ./test a.xml
>     In this case, an instance of LocalFileInputSource is created and passed to the XercesDomParser::parse()
>     Result: parse success.
> Note: 
> [1] I have not set any encoding for StdInInputSource object.
> [2] The default locale on the RHAS 3.0 machine is en.US.utf-8
> [3] The xml file specifies and encoding of UTF-8 on the first line.
> What could be the problem? Your response, and help would be greatly appreciated.
> Thanks,
> Aditya Kulkarni

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail: c-dev-unsubscribe@xerces.apache.org
For additional commands, e-mail: c-dev-help@xerces.apache.org

View raw message