xerces-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bovy, Stephen J" <STEPHEN.B...@ca.com>
Subject RE: z/OS and OS/390 runConfigure ???
Date Wed, 28 Apr 2004 18:49:30 GMT
Thanks for the info David.   

I will tuck this away in a safe place for future refference. 

-----Original Message-----
From: David Cargill [mailto:cargilld@ca.ibm.com] 
Sent: Wednesday, April 28, 2004 11:14 AM
To: xerces-c-dev@xml.apache.org
Subject: RE: z/OS and OS/390 runConfigure ???





Hi,
To build xerces-c on 390 we just use "configure" rather than using the
runConfigure wrapper script so that is why the runConfigure script
hasn't been modified.  I will see what we can do about getting
runConfigure modified for 390 for the next release...

The environment variables I set (the last time I built it which was a
while
ago) before calling configure are:
export TRANSCODER=Uniconv390  (you might want NATIVE instead).
export MESSAGELOADER=INMEM
export USELIBWWW=0
export NETACCESSOR=Socket
export CC=c89
export CXX=c++
unset _CXX_CXXSUFFIX
export _CXX_CCMODE=1
export _C89_CCMODE=1

after running configure,
export _CXX_CXXSUFFIX=cpp
gmake

Regards,
David A. Cargill


 

             "Bovy, Stephen J"

             <STEPHEN.Bovy@ca.

             com>
To 
                                       <xerces-c-dev@xml.apache.org>

             04/28/2004 01:28
cc 
             PM

 
Subject 
                                       RE: z/OS and OS/390
runConfigure  
             Please respond to         ???

               xerces-c-dev

 

 

 

 

 





Then why haven't those fixes been merged back into the Xerces tree ???

Is IBM not being a good citizen in this matter ???

Is IBM Purposefully and intentionally maintaining a "separate" "fork" of
Xerces ?????

The main reason I ask this , is because the official IBM toolkit is
always way way behind the current Xerces version.

And on the Alpha works site there are no binary builds provided for
z/OS, which is frustratingly stupid.


From: moshief, daniel [mailto:moshief_daniel@emc.com]
Sent: Wednesday, April 28, 2004 7:07 AM
To: 'xerces-c-dev@xml.apache.org'
Subject: z/OS and OS/390 runConfigure ???



The general question is: can xerces be compiled and successfully built
and function
correctly?    IBM XML Toolkit support has indicated that the xerces code
would need updates
for it to function (ie that IBM XML Toolkit support does).






Content-Type: text/plain;
        charset="us-ascii"
Subject: z/OS and OS/390   runConfigure ???
Date: Tue, 27 Apr 2004 13:42:59 -0400
From: Bovy, Stephen J <STEPHEN.Bovy@ca.com>



How come the runConfigure script has no support for z/OS and/or OS/390
????




---------------------------------------------------------------------
To unsubscribe, e-mail: xerces-c-dev-unsubscribe@xml.apache.org
For additional commands, e-mail: xerces-c-dev-help@xml.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: xerces-c-dev-unsubscribe@xml.apache.org
For additional commands, e-mail: xerces-c-dev-help@xml.apache.org


Mime
View raw message