xerces-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bovy, Stephen J" <STEPHEN.B...@ca.com>
Subject Wrapper4InputSource IBM parse gets S01, help !!!!
Date Thu, 22 Apr 2004 19:40:57 GMT
I have the following code which I am using with 

the IBM toolkit 1.6 which is xerces 2.2

MemBufInputSource* memBufIS = NULL;      
Wrapper4InputSource* domBufIS = NULL;    

memBufIS = new MemBufInputSource                    
(                                                   
    (const XMLByte*) sfile.ipc->pbuff               
    , sfile.ipc->leng                               
    , gMemBufId                                     
    , false                                         
);                                                  

fprintf ( stderr, "MemBufInput created\n"); 

domBufIS = new Wrapper4InputSource ( memBufIS );     

fprintf ( stderr, "DomBufInput created\n"); 

static const XMLCh gLS   = { chLatin_L, chLatin_S, chNull };        
                                                                    
impl = DOMImplementationRegistry::getDOMImplementation(gLS);
                                                                    
parser =                                                    
  ((DOMImplementationLS*)impl)->                            
  createDOMBuilder ( DOMImplementationLS::MODE_SYNCHRONOUS, 0 );    

fprintf ( stderr, "Begin Parse\n");

doc = parser->parse(*domBufIS);    

I am getting a S01 when the parser is invoked, any suggestions would be
appreciated !! 





---------------------------------------------------------------------
To unsubscribe, e-mail: xerces-c-dev-unsubscribe@xml.apache.org
For additional commands, e-mail: xerces-c-dev-help@xml.apache.org


Mime
View raw message