xerces-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patrick Townsend" <Patrick.Townse...@patownsend.com>
Subject Error building Xerces C++ on AS/400 (iSeries)
Date Sun, 07 Mar 2004 20:36:37 GMT
Hello,

I am having a problem building the Xerces C++ 2.5.0 application on the IBM
AS/400 (V5R2). I've installed the gmake utility, and that installation was
successful (no errors). I've set the environment variables for runConfigure
as follows:

  ADDENVVAR  ENVVAR(XERCESCROOT) VALUE('/XML4C/xerces250')  /* Not really
XML4C */
  ADDENVVAR  ENVVAR(MAKE) VALUE('/usr/bin/gmake')
  ADDENVVAR  ENVVAR(OUTPUTDIR) +
      VALUE('ALLXER100')

I go into the /XML4C/xerces250/src/xercesc directory and run the
runConfigure script like this:

  runConfigure -p os400 -x icc -c icc -m inmem -t Iconv400

I've made an edit for the getopt message, but am still getting one error
message like this:

   "getopts: 001-0015 Required operand(s) not specified."

It does not cause a halt. This is displayed as a part of the configure run:

 Generating makefiles with the following options ...
 Platform: os400
 C Compiler: icc
 C++ Compiler: icc
 Message Loader: inmem
Net Accessor: socket
Transcoder: Iconv400
Thread option: pthread
bitsToBuild option: 32
Extra compile options:
Extra link options:
Extra configure options:
Debug is OFF
NATIVE OS400 BUILD

The compiler checks seem to go OK. I get this error however:

   "checking host system type... Invalid configuration `AS400-OS400':
machine `AS400-OS400' not recognized"

There are lots of messages about creating make files, followed by the
suggestion to run gmake. I run gmake and get these errors:

gmake
Preparing the directory structure for a build ...
mkdir -p /XML4C/xerces250/obj/UNKNOWN
mkdir: 001-2128 Error found creating directory /XML4C/xerces250/obj/UNKNOWN.
File exists.
GMAKE: [Prepare] Error 1 (ignored)
mkdir -p /XML4C/xerces250/lib
mkdir: 001-2128 Error found creating directory /XML4C/xerces250/lib. File
exists.
GMAKE: [Prepare] Error 1 (ignored)
/usr/bin/gmake -C util includes
GMAKE[1]: Entering directory `/XML4C/xerces250/src/xercesc/util'
mkdir -p /XML4C/xerces250/include/xercesc/util
mkdir: 001-2128 Error found creating directory /XML4C/xerces250/include/xer
GMAKE[1]: [pubheaders] Error 1 (ignored)
cp -fp ArrayIndexOutOfBoundsException.hpp AutoSense.hpp /* lots more follow
*/
/XML4C/xerces250/include/xercesc/util
/usr/bin/gmake -C Platforms includes
GMAKE[2]: Entering directory `/XML4C/xerces250/src/xercesc/util/Platforms'
/usr/bin/gmake -C  includes
GMAKE: Entering an unknown directory
GMAKE: *** includes: No such path or directory..  Stop.
GMAKE: Leaving an unknown directory
GMAKE[2]: *** [includes] Error 2
GMAKE[2]: Leaving directory `/XML4C/xerces250/src/xercesc/util/Platforms'
GMAKE[1]: *** [includes] Error 2
GMAKE[1]: Leaving directory `/XML4C/xerces250/src/xercesc/util'
GMAKE: *** [Prepare] Error 2
$


I am woefully ignorant about gmake and UNIX make in general. Any help would
be appreciated.

I'll be glad, by the way, to contribute the AS/400 binary and build
instructions when it gets working.

Thanks,
Patrick

Mime
View raw message