www-repository mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: Maven deploy to repository.a.o comes back with Forbidden
Date Mon, 29 Dec 2014 21:14:55 GMT
Looks like the Flink LDAP group has not yet been created.

The top level issue is here:
https://issues.apache.org/jira/browse/INFRA-8909


On 29 December 2014 at 20:52, Brian Fox <brianf@infinity.nu> wrote:

> According to what Nexus sees in LDAP, you aren't part of the Flink group.
>
> Robert appears to have had the flink role manually added to his user id in
> Nexus. You should check with infra that the flink ldap group is correctly
> created.
>
> ​
>
> On Sun, Dec 28, 2014 at 3:40 AM, Márton Balassi <balassi.marton@gmail.com>
> wrote:
>
>> Hey,
>>
>> I'm Marton, newbie release manager for freshly a graduated TLP, Flink.
>> I'm having an issue with the maven deploy to repository.a.o.
>>
>> Even though I can login successfully on the webui, the maven deploy from
>> a cli gives me "Access denied to:
>> https://repository.apache.org/service/local/staging/deploy/maven2/org/apache/flink/flink-parent/0.8.0-hadoop2/flink-parent-0.8.0-hadoop2.pom,
>> ReasonPhrase: Forbidden."
>>
>> I have two guesses: maybe my credentials are wrong (I doubt that, added
>> them to the settings xml of maven) or perhaps I do not have the right to
>> create directories on the machine under repository.a.o.
>>
>> To be more specific:
>>
>> Command executed:
>>
>> mvn clean deploy -Prelease,docs-and-source --settings deploysettings.xml
>> -DskipTests -Dgpg.executable=$GPG -Dgpg.keyname=$GPG_KEY
>> -Dgpg.passphrase=$GPG_PASSPHRASE -DretryFailedDeploymentCount=10 -X
>>
>> Relevant verbose output:
>>
>> [DEBUG] Using connector WagonRepositoryConnector with priority 0 for
>> https://repository.apache.org/service/local/staging/deploy/maven2 as
>> mbalassi
>> Uploading:
>> https://repository.apache.org/service/local/staging/deploy/maven2/org/apache/flink/flink-parent/0.8.0/flink-parent-0.8.0.pom
>> [WARNING] Encountered issue during deployment: Failed to deploy
>> artifacts: Could not transfer artifact
>> org.apache.flink:flink-parent:pom:0.8.0 from/to apache.releases.https (
>> https://repository.apache.org/service/local/staging/deploy/maven2):
>> Access denied to:
>> https://repository.apache.org/service/local/staging/deploy/maven2/org/apache/flink/flink-parent/0.8.0/flink-parent-0.8.0.pom,
>> ReasonPhrase: Forbidden.
>> [DEBUG]
>> org.apache.maven.artifact.deployer.ArtifactDeploymentException: Failed to
>> deploy artifacts: Could not transfer artifact
>> org.apache.flink:flink-parent:pom:0.8.0 from/to apache.releases.https (
>> https://repository.apache.org/service/local/staging/deploy/maven2):
>> Access denied to:
>> https://repository.apache.org/service/local/staging/deploy/maven2/org/apache/flink/flink-parent/0.8.0/flink-parent-0.8.0.pom,
>> ReasonPhrase: Forbidden.
>> at
>> org.apache.maven.artifact.deployer.DefaultArtifactDeployer.deploy(DefaultArtifactDeployer.java:141)
>>
>> Any help on this would be welcome. Thanks in advance,
>>
>> Marton
>>
>
>

Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message