www-repository mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bobby Evans <bo...@apache.org>
Subject getting a 401 deploying a build to nexus
Date Fri, 07 Sep 2012 19:07:47 GMT
I am trying to do a point release of Hadoop, but I am getting a 401
error whenever I try to deploy the release to nexus.  I have my maven
settings.xml set up

<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
                      http://maven.apache.org/xsd/settings-1.0.0.xsd">
  <servers>
    <server>
     <id>apache.snapshots.https</id>
     <username>${apache_user}</username>
     <password>${apache_password}</password>
     <filePermissions>664</filePermissions>
     <directoryPermissions>775</directoryPermissions>
    </server>
    <server>
     <id>apache.releases.https</id>
     <username>${apache_user}</username>
     <password>${apache_password}</password>
     <filePermissions>664</filePermissions>
     <directoryPermissions>775</directoryPermissions>
    </server>
  </servers>
</settings>

and if I use the same command for a snapshot version everything works
just fine.  It is only when I try to deploy a real release version I
get the 401.

mvn deploy -Psign,src,native,dist -Dmaven.test.skip.exec=true
-Dcontainer-executor.conf.dir=/etc/hadoop
...
1:50 [ERROR] Failed to execute goal
org.apache.maven.plugins:maven-deploy-plugin:2.5:deploy
(default-deploy) on project hadoop-main: Failed to deploy artifacts:
Could not transfer artifact org.apache.hadoop:hadoop-main:pom:0.23.3
from/to apache.staging.https
(https://repository.apache.org/service/local/staging/deploy/maven2):
Failed to transfer file:
https://repository.apache.org/service/local/staging/deploy/maven2/org/apache/hadoop/hadoop-main/0.23.3/hadoop-main-0.23.3.pom.
Return code is: 401 -> [Help 1]

I assume I must be missing some permissions somewhere, and would like
to know what I need to do to get the proper permissions added.

Thanks for your help,

Bobby Evans

Mime
View raw message