www-repository mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: Weird staging problem with md5/sha1 for chemistry-jar-resource-bundle
Date Wed, 02 Mar 2011 13:05:43 GMT
On 2 March 2011 12:52, Gabriele Columbro <gabriele@apache.org> wrote:
> Hi guys,
>
> I'm trying to do a 1st release for a Chemistry subproject
> chemistry-jar-resource-bundle, a simple JAR resource bundle used by
> Chemistry OpenCMIS build.
>
> The weird thing is that after a successful "release:prepare
> release:perform" using Maven 2.2.1 on OSX 10.6, when I try to close
> the staging repo (e.g. [2]) I get lots of md5 / sha1 errors like:
>
>> Staging ruleset evaluation on repository 'org.apache.chemistry-074 (u:gabriele, a:83.163.45.170)'
has failed
>> Staging Checksum Validation
>>    -Incorrect SHA1: '/org/apache/chemistry/resources/chemistry-jar-resource-bundle/0.3.0/chemistry-jar-resource-bundle-0.3.0-sources.jar.sha1'.
>>    -Incorrect MD5: '/org/apache/chemistry/resources/chemistry-jar-resource-bundle/0.3.0/chemistry-jar-resource-bundle-0.3.0-sources.jar.md5'.
>>    -Incorrect SHA1: '/org/apache/chemistry/resources/chemistry-jar-resource-bundle/0.3.0/chemistry-jar-resource-bundle-0.3.0.pom.sha1'.
>>    -Incorrect MD5: '/org/apache/chemistry/resources/chemistry-jar-resource-bundle/0.3.0/chemistry-jar-resource-bundle-0.3.0.pom.md5'.
>>    -Incorrect SHA1: '/org/apache/chemistry/resources/chemistry-jar-resource-bundle/0.3.0/chemistry-jar-resource-bundle-0.3.0.jar.sha1'.
>>    -Incorrect MD5: '/org/apache/chemistry/resources/chemistry-jar-resource-bundle/0.3.0/chemistry-jar-resource-bundle-0.3.0.jar.md5'.
>>    -Incorrect SHA1: '/org/apache/chemistry/resources/chemistry-jar-resource-bundle/0.3.0/chemistry-jar-resource-bundle-0.3.0-source-release.zip.sha1'.
>>    -Incorrect MD5: '/org/apache/chemistry/resources/chemistry-jar-resource-bundle/0.3.0/chemistry-jar-resource-bundle-0.3.0-source-release.zip.md5'.
>
> The POM is very simple [1] and I followed [3] and [4].
>
> Checking the problematic artifacts in the staging repo shows in fact
> that the *.md5 and *.sh1 files contain a hash which is NOT the one of
> the corresponding artifact (while they match in my local repo).
>
> I also tried to drop the repo and re-try the procedure with no results.
>
> I'm a bit puzzled since this never happened before (especially in the
> much more complex release of OpenCMIS), so there must be something
> really stupid I'm missing.
>
> Thanks in advance for any suggestion,

Which version of Maven are you using?

> Gab
>
> [1] http://svn.apache.org/repos/asf/chemistry/chemistry-jar-resource-bundle/trunk/pom.xml
> [2] https://repository.apache.org/content/repositories/orgapachechemistry-074/
> [3] https://docs.sonatype.org/display/Repository/Central+Sync+Requirements
> [4] http://www.apache.org/dev/publishing-maven-artifacts.html
>
> --
> Eng. Gabriele Columbro
> Open source and ECM Architect
> Alfresco Ltd. - http://www.alfresco.com
> -----------------------------------------
> http://twitter.com/#!/mindthegabz
> -----------------------------------------
> "Keyboard not found.
>  Press F1 to continue"
> ----------------------------------------
>

Mime
View raw message