www-repository mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felix Meschberger <fmesc...@gmail.com>
Subject Re: Changes on repository.apache.org?
Date Fri, 04 Mar 2011 10:25:10 GMT
Hi,

Am Freitag, den 04.03.2011, 10:11 +0000 schrieb Stuart McCulloch:
> On 4 March 2011 10:02, Felix Meschberger <fmeschbe@gmail.com> wrote:
>         Hi,
>         
>         Some more background: These scripts use wget to download the
>         release
>         candidate. According to the wget man page wget respects
>         robots.txt 
> 
> 
> FWIW you could add the following line to your local ~/.wgetrc
> 
> 
>    robots=off
> 
> 
> this tells wget to ignore robots.txt - the script should then work

Thanks for the hint. Carsten found this out, too, and it works indeed.

Regards
Felix

>  
>         which in turn contains:
>         
>         > User-agent: *
>         > Disallow: /content/
>         > Disallow: /service/
>         > Allow: /
>         > Allow: /content/sites/
>         
>         Could it be that this prevents wget from working and that
>         robots.txt has
>         recently been changed (IIRC I could get a RC with the scripts
>         on
>         Monday).
>         
>         Thanks and Regards
>         Felix
>         
>         
>         Am Freitag, den 04.03.2011, 08:23 +0100 schrieb Carsten
>         Ziegeler: 
>         
>         > Hi,
>         >
>         > in the Felix and Sling project we use a script to download
>         artifacts
>         > from the staging repository to verify the releases.
>         > It stopped working at some point this week.
>         >
>         > The script uses wget and fetches index.html and traverses
>         the links of
>         > this html page recursively. It seems that now index.html is
>         not
>         > available anymore.
>         >
>         > While
>         >
>         https://repository.apache.org/content/repositories/orgapachefelix-003/org/apache/felix/
>         > returns the html
>         >
>         https://repository.apache.org/content/repositories/orgapachefelix-003/org/apache/felix/index.html
>         >
>         > does not.
>         >
>         > Is anyone aware of any changes here? Can we restore the old
>         behaviour?
>         > Or does someone know how to instruct wget to not append
>         index.html (I
>         > couldn't figure it out)
>         >
>         > Regards
>         > Carsten
>         
>         
>         
> 
> 
> 
> -- 
> Cheers, Stuart



Mime
View raw message