www-repository mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: Self-signed certificate error reported when using wget
Date Fri, 07 Jan 2011 21:07:36 GMT
On 7 January 2011 19:54, Brian Demers <bdemers@sonatype.com> wrote:
>
> Tt depends on your OS and how you installed wget.  For example mac ports
> wget does not tie into the system certs (if I remember correctly) but
> version of curl provided does.  Something like that anyway.
>

Thanks, the curl reference has helped.

wget reports a warning on both people.a.o and my Windows XP box.

curl is happy on people, but warns on Windows.

I've discovered that

wget --ca-certificate /etc/ssl/cert.pem ...

works on people.a.o, and both curl and wget work on Windows with that
cert.pem file, so problem solved!

Thanks.

>
> On Fri, Jan 7, 2011 at 1:58 PM, sebb <sebbaz@gmail.com> wrote:
>>
>> I use wget to download release candidates for reviewing, but I get the
>> following message:
>>
>> ERROR: cannot verify repository.apache.org's certificate, issued by
>> `/C=US/ST=Arizona/L=Scottsdale/O=GoDaddy.com,
>> Inc./OU=http://certificates.godaddy.com/repository/CN=Go Daddy Secure
>> Certification Authority/serialNumber=07969287':
>>  Self-signed certificate encountered.
>> To connect to repository.apache.org insecurely, use
>> `--no-check-certificate'.
>>
>> [I don't get the same error when using a browser.]
>>
>> Although I can use the --no-check-certificate option, this is not ideal.
>>
>> Is there a way to add the certificate such that wget can download from
>> r.a.o without reporting the error?
>
>

Mime
View raw message