www-repository mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: Re: Problems uploading bundle to Sonatype
Date Tue, 07 Dec 2010 16:34:36 GMT
On 7 December 2010 15:57,  <gk_brown@verizon.net> wrote:
> Nexus definitely supports them - we have deployed our last 3 releases this way. Something
must have changed on the Sonatype end, since we didn't change the process we use to generate
the bundles...
>
> Dec 7, 2010 10:06:20 AM, repository@apache.org wrote:
>
> ===========================================
>
> On 7 December 2010 14:59,   wrote:
>> There are POMs in the bundles. For example, if you unzip pivot-2.0-bundle.jar, you
should see:
>
> AFAIK Maven repos provide the POMs etc as separate files, as well as
> in some of the jars.
>
> I've never tried uploading using bundles; perhaps Nexus does not support them.
>> /META-INF
>> pivot-2.0.pom.asc
>> pivot-2.0.pom.sha1
>> pom.xml

How does Nexus know that the sig and hash belong to the pom.xml?

If you look in the pom, what version do you see?

I see:

<version>@VERSION@</version>

so I don't see how Nexus can marry the POM with the sig and hash.

>> Do you not see these?
>
> Yes, but does Nexus?
>
>> G
>>
>> Dec 7, 2010 09:54:11 AM, repository@apache.org wrote:
>>
>> ===========================================
>>
>> On 7 December 2010 14:49,   wrote:
>>> Problems uploading bundle to Sonatype
>>> MIME-Version: 1.0
>>> Content-Type: text/plain; charset=UTF-8
>>> Content-Transfer-Encoding: 7bit
>>> X-Originating-IP: [137.254.4.9]
>>>
>>> Hi,
>>>
>>> The Pivot team is getting ready to release Apache Pivot 2.0, and we are having
trouble uploading our generated Maven bundles to the repository manager at https://repository.apache.org.
The bundles are located here:
>>>
>>> http://people.apache.org/~tvolkert/maven/pivot/v2.0/
>>>
>>> When I try to upload the root bundle (pivot-2.0-bundle.jar), I get the following
error:
>>>
>>> Artifact upload failed.
>>> [pivot-2.0.pom.sha1, pivot-2.0.pom.asc] are invalid maven artifacts
>>
>> There are no POMs present with the bundles, nor any sigs or hashes.
>> That could be the cause. If so, the error message is misleading...
>>
>>>
>>> Your help would be very much appreciated in resolving this issue.
>>>
>>> Thanks,
>>> Greg
>>>
>>
>

Mime
View raw message