www-repository mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Craig L Russell <craig.russ...@oracle.com>
Subject Re: Sync with Apache not working ?
Date Wed, 20 Oct 2010 22:34:25 GMT
On behalf of the Apache JDO project, Thanks!

Craig

Andy, when you've verified everything can you please close the JIRA?

On Oct 20, 2010, at 9:16 AM, Brian Fox wrote:

> Just to close the loop, this issue was filed
> https://issues.apache.org/jira/browse/INFRA-3081 and I believe
> everything is sorted out now. When you move to using Maven2, if you
> have any issues deploying please let us know (via INFRA jira so it
> doesn't get lost).
>
> --Brian
>
> On Tue, Oct 19, 2010 at 1:08 PM, Craig L Russell
> <craig.russell@oracle.com> wrote:
>> Hi Brian,
>>
>> Thanks, will do.
>>
>> Craig
>>
>> On Oct 19, 2010, at 10:05 AM, Brian Fox wrote:
>>
>>> Hi Craig,
>>> No offense intended, I used to use Kodo once upon a time and didn't
>>> latch on to the relationship of the OpenJDO project and the  
>>> javax.jdo
>>> artifacts in my previous mail. We have historically had a free-for- 
>>> all
>>> in who deploys what to Central and it's one of the biggest pain  
>>> points
>>> we have trying to track stuff down.
>>>
>>> What I would suggest is to go here
>>> http://www.apache.org/dev/publishing-maven-artifacts.html and file a
>>> jira for your projects and enumerate the (Maven2) groupIds so I can
>>> make sure they are properly configured in the apache repository and
>>> central sync.We can work together through that subsequent Jira to  
>>> get
>>> everything sorted out.
>>>
>>> Brian
>>>
>>> On Tue, Oct 19, 2010 at 12:52 PM, Craig L Russell
>>> <craig.russell@oracle.com> wrote:
>>>>
>>>> Hi Brian,
>>>> As a long time Apache project, I'd like to ask you to add  
>>>> org.apache.jdo
>>>> and
>>>> javax.jdo to the list of auto-synced artifacts that can be  
>>>> obtained from
>>>> maven central. These group ids are published by an official Apache
>>>> project
>>>> and I think deserve the same respect that other org.apache  
>>>> projects get.
>>>> Thanks,
>>>> Craig
>>>>
>>>> Begin forwarded message:
>>>>
>>>> From: Andy Jefferson <lists@datanucleus.org>
>>>> Date: October 19, 2010 6:51:40 AM PDT
>>>> To: jdo-dev@db.apache.org
>>>> Subject: Fwd: Re: Sync with Apache not working ?
>>>> Reply-To: jdo-dev@db.apache.org
>>>> See attached.
>>>>
>>>> Apache (Maven) no longer sync Apache M1 repos and so Apache JDO
>>>> artifacts are no longer put on IBiblio.
>>>>
>>>> Anyone got the time to sort this out ?
>>>>
>>>> --
>>>> Andy
>>>> DataNucleus (http://www.datanucleus.org)
>>>>
>>>> From: Brian Fox <brianf@infinity.nu>
>>>> Date: October 19, 2010 6:39:13 AM PDT
>>>> To: Maven Developers List <dev@maven.apache.org>
>>>> Cc: lists <lists@datanucleus.org>
>>>> Subject: Re: Sync with Apache not working ?
>>>>
>>>>
>>>> On Tue, Oct 19, 2010 at 9:07 AM, Andy Jefferson <lists@datanucleus.org

>>>> >
>>>> wrote:
>>>>
>>>> Hi,
>>>>
>>>> the Apache JDO project made a release in late July (JDO 3.0).  
>>>> They put
>>>> the
>>>>
>>>> artifacts in the Apache M1 repo for syncing, see
>>>>
>>>> http://people.apache.org/repo/m1-ibiblio-rsync-repository/javax.jdo/jars/
>>>>
>>>> The m1 repository is no longer synced
>>>>
>>>>
>>>> in particular I'm referring to
>>>>
>>>> jdo-api-3.0.jar
>>>>
>>>> And in the Apache M2 repo they updated the "maven-metadata.xml"  
>>>> file as
>>>> per
>>>>
>>>> their previous releases, see
>>>>
>>>>
>>>> http://people.apache.org/repo/m2-ibiblio-rsync-repository/javax/jdo/jdo-api/
>>>>
>>>>
>>>> The sync only pulls in org.apache.* and other selected group ids  
>>>> from
>>>> commons. If you have something external to that, it should  
>>>> instead use
>>>> the 3rd party bundle process:
>>>>
>>>> https://docs.sonatype.org/display/Repository/Uploading+3rd-party+Artifacts+to+Maven+Central
>>>>
>>>> In the future, questions about central should go here:
>>>> https://issues.sonatype.org/browse/MVNCENTRAL
>>>> and questions about the Apache repository should go here:
>>>> https://issues.apache.org/jira/browse/INFRA
>>>>
>>>>
>>>> When I look at the M1 and M2 repos on IBiblio I cannot find these  
>>>> jars.
>>>> Why
>>>> is
>>>>
>>>> this ? and how can they make their way into the place they need  
>>>> to be
>>>>
>>>>
>>>>
>>>> PS. Please reply to my email if possible since not subscribed to  
>>>> the dev
>>>>
>>>> mailing list
>>>>
>>>>
>>>> Regards
>>>>
>>>> --
>>>>
>>>> Andy
>>>>
>>>> DataNucleus (http://www.datanucleus.org)
>>>>
>>>> ---------------------------------------------------------------------
>>>>
>>>> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
>>>>
>>>> For additional commands, e-mail: dev-help@maven.apache.org
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> Craig L Russell
>>>>
>>>> Architect, Oracle
>>>>
>>>> http://db.apache.org/jdo
>>>>
>>>> 408 276-5638 mailto:Craig.Russell@oracle.com
>>>>
>>>> P.S. A good JDO? O, Gasp!
>>>>
>>
>> Craig L Russell
>> Architect, Oracle
>> http://db.apache.org/jdo
>> 408 276-5638 mailto:Craig.Russell@oracle.com
>> P.S. A good JDO? O, Gasp!
>>
>>

Craig L Russell
Architect, Oracle
http://db.apache.org/jdo
408 276-5638 mailto:Craig.Russell@oracle.com
P.S. A good JDO? O, Gasp!


Mime
View raw message