www-repository mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <dk...@apache.org>
Subject Re: Nexus release not working / promote not available for httpcomponents
Date Mon, 16 Aug 2010 13:34:07 GMT
On Monday 16 August 2010 9:29:24 am Brian Demers wrote:
> +1
> I like that

I agree.   The first time I clicked the promote button, I had a panic attack 
as the message said it was successful, but it hadn't shown up in the release 
repo yet and the staging repo was gone.   Had a major "where did my artifacts 
go?!?!" panic attack.   

Dan


> 
> On Mon, Aug 16, 2010 at 6:47 AM, sebb <sebbaz@gmail.com> wrote:
> > On 10 August 2010 19:13, Brian Demers <bdemers@sonatype.com> wrote:
> > > I did not set the permissions correctly when I imported the projects
> > > into nexus.
> > > FYI: The UI reported it was successful, although what it really means
> > > is that the rules/conditions passed allowing the staging repository to
> > > be 'released', the actual copying of the files from one repository to
> > > the release repo is asynchronous.
> > 
> > Perhaps the confirmation message should be reworded to make that clear?
> > 
> > e.g. change
> > 
> > "The selected repositories have successfully been released"
> > 
> > to
> > 
> > "The selected repositories have been scheduled for release"
> > 
> > > On Tue, Aug 10, 2010 at 9:25 AM, sebb <sebbaz@gmail.com> wrote:
> > >> On 10 August 2010 14:23, Brian Fox <brianf@sonatype.com> wrote:
> > >> > I see one repo that is staged: httpcomponents-009 which has
> > >> > org.apache.httpcomponents.project:4.1 in it. Is this the one you're
> > >> > having
> > >> > trouble with?
> > >> 
> > >> Yes.
> > >> 
> > >> > On Tue, Aug 10, 2010 at 5:04 AM, sebb <sebbaz@gmail.com> wrote:
> > >> >> We have started using Nexus in HttpComponents, and want to use
it
> > >> >> to release the parent POM.
> > >> >> 
> > >> >> Upload and Close worked fine, however there it stops working.
> > >> >> 
> > >> >> The promote button is not enabled.
> > >> >> The release button is enabled, and appears to work - we get the
> > >> >> message "The selected repositories have successfully been released"
> > >> >> - however the product remains in the closed state and does not
> > >> >> appear
> > 
> > in
> > 
> > >> >> the repo.
> > >> >> 
> > >> >> The process can be repeated, with the same results.
> > >> >> 
> > >> >> What gives?
> > >> >> 
> > >> >> A problem with the HttpComponents configuration?
> > >> >> A bug in Nexus?

-- 
Daniel Kulp
dkulp@apache.org
http://dankulp.com/blog

Mime
View raw message