www-repository mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carlos Sanchez <car...@apache.org>
Subject Re: [maven deploy] cannot deploy artifacts to rsync repository
Date Wed, 21 Apr 2010 07:06:14 GMT
seems you have a DNS issue

On Wed, Apr 21, 2010 at 6:39 AM, Leonardo Uribe <lu4242@gmail.com> wrote:
> Hi
>
> Trying to release some artifacts I founded this error:
>
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Error installing artifact's metadata: repository metadata for:
> 'artifact org.apache.myfaces.test:myfaces-test-project' could not be
> retrieved from repository: myfaces-staging due to an error: Exit code: 1 -
> ssh: Could not resolve hostname people.apache.org: Temporary failure in name
> resolution
>
> only some artifacts are uploaded, but at random the transaction is aborted
> (it uploads some files). I'm doing the same stuff as always, so I'm sure it
> is not an error on my local configuration.
>
> Is anything wrong in the repo? The same command on my machine:
>
> mvn clean deploy
> -DaltDeploymentRepository=myfaces-staging::default::scpexe://people.apache.org/www/people.apache.org/repo/m2-ibiblio-rsync-repository
> -Psign-artifacts -DperformRelease=true -Dpassphrase=???
>
> but pointing to my local machine works without problem.
>
> What can I do for deploy this artifacts without destroy the maven metadata?
>
> best regards,
>
> Leonardo Uribe
>
>

Mime
View raw message