www-repository mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gav..." <ga...@16degrees.com.au>
Subject From Jira INFRA-2352 - Build artifacts not getting deployed for Camel
Date Fri, 01 Jan 2010 11:26:55 GMT
Not sure if this is a Repository or a Hudson thing that can be solved, but
the issue
Has been languishing in our Jira since November without any comment. Can
someone take
A look please at https://issues.apache.org/jira/browse/INFRA-2352 

Details from the issue pasted below for convenience.

Gav...

--------

>From Jonathan Anstey:

I recently added source jars to the Camel build in Hudson. To do this, I
added a profile
http://svn.apache.org/viewvc/camel/trunk/pom.xml?r1=882039&r2=884081&pathrev
=884081 and then added -Psource-jar to the Maven options in the Camel build
config http://hudson.zones.apache.org/hudson/job/Camel 

So now Hudson reports the new build artifacts are generated. Looking at the
camel-core module for instance, Hudson reports these artifacts: 

    * pom.xml [fingerprint] 
    * camel-core-2.1-SNAPSHOT-tests.jar [fingerprint] 
    * camel-core-2.1-SNAPSHOT-sources.jar [fingerprint] 
    * camel-core-2.1-SNAPSHOT.jar [fingerprint] 

So I thought that the camel-core-2.1-SNAPSHOT-sources.jar file would be
deployed like the rest. Not so. Looking at
https://repository.apache.org/content/repositories/snapshots/org/apache/came
l/camel-core/2.1-SNAPSHOT/ only the other build artifacts are deployed...
does anyone know what could be happening here? Or should I try and contact
the Hudson team about this?



Mime
View raw message