www-repository mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carlos Sanchez" <car...@apache.org>
Subject Re: Maven artifacts for Batik
Date Fri, 30 Nov 2007 02:30:58 GMT
The best person that will help you is a user of Batik that uses Maven, Lars?
see some comments inline

On Nov 29, 2007 9:21 AM, Cameron McCormack <cam@mcc.id.au> wrote:
> Hi all.
>
> [Apologies for my wanton cross-posting.]
>
> Since Batik's release is coming up soon, I'd like to get the Maven stuff
> in order.  Lars Trieloff helpfully provided some POMs for the 1.7beta1
> release in http://issues.apache.org/bugzilla/show_bug.cgi?id=42320 and
> in that bug he says these were uploaded to
> http://repo1.maven.org/maven2/batik/, although looking there the latest
> versions I can see are for the 1.6 release.
>
> I want to generate the artifacts from the Ant build script (now that I
> have recomputed the dependencies between the jars) and FOP's
> "maven-artifacts" build target looks like a good one to copy.  I have a
> few questions though.
>
> First, should I keep the groupId as "batik"?  It seems inconsistent with
> those for FOP and Commons, which are using "org.apache.xmlgraphics".
> Would it be problematic to change this?

not too problematic, just a bit annoying for some users, but it should
be done at some point
groupId should probably be org.apache.xmlgraphics.batik

>
> Second, how do I deal with the issue of the mutual dependency between
> FOP and Batik?  The Batik 1.7 release will depend on Fop 0.93, but in
> http://people.apache.org/repo/m2-ibiblio-rsync-repository/org/apache/xmlgraphics/fop/0.93/fop-0.93.pom
> it says that FOP 0.93 depends on the 1.6-1 versions of the various Batik
> artifacts.  Is that what the <exclusions> element in the POM file is
> used for?

is it a real dependency or it's just that the fop pom is messed up?
yes, you can depend in fop and add an exclusion for batik there

>
> Third, since Batik relies on a patched version of Rhino, I won't be able
> to add a dependency on js-1.6R5.jar artifact.  Do I need to create a
> special artifact that contains the patched Rhino, e.g. a
> batik-js-1.7.jar?

or you could put a js-1.6R5patched.jar under
org.apache.xmlgraphics.batik group with its own pom. Make sure in the
description you state clearly that it's a patched version to avoid
confusion

>
> Fourth, once the release has been made, does the release manager just
> upload the artifacts to
> http://people.apache.org/repo/m2-ibiblio-rsync-repository/ themselves?

if you don't use maven2 to build I'd put them in
http://people.apache.org/repo/m1-ibiblio-rsync-repository/org.apache.xmlgraphics.batik
/jars and /poms

>
> Thanks,
>
> Cameron
>
> --
> Cameron McCormack, http://mcc.id.au/
>         xmpp:heycam@jabber.org  ▪  ICQ 26955922  ▪  MSN cam@mcc.id.au
>



-- 
I could give you my word as a Spaniard.
No good. I've known too many Spaniards.
                             -- The Princess Bride
Mime
View raw message