www-legal-discuss mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jaroslav Tulach (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (LEGAL-361) Can Apache NetBeans (incubating) use adjusted org.eclipse.osgi_3.9.1.v20140110-1610.jar
Date Tue, 13 Feb 2018 16:13:01 GMT

    [ https://issues.apache.org/jira/browse/LEGAL-361?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16361911#comment-16361911
] 

Jaroslav Tulach edited comment on LEGAL-361 at 2/13/18 4:12 PM:
----------------------------------------------------------------

Proposing fix of this issue as [#421|https://github.com/apache/incubator-netbeans/pull/421]
- we did technical review. Somebody from legal shall comment here and confirm the fix is sufficient.


was (Author: jtulach):
Proposing the changes as https://github.com/apache/incubator-netbeans/pull/421

> Can Apache NetBeans (incubating) use adjusted org.eclipse.osgi_3.9.1.v20140110-1610.jar
> ---------------------------------------------------------------------------------------
>
>                 Key: LEGAL-361
>                 URL: https://issues.apache.org/jira/browse/LEGAL-361
>             Project: Legal Discuss
>          Issue Type: Question
>            Reporter: Jan Lahoda
>            Priority: Major
>
> It has been requested here:
> [http://mail-archives.apache.org/mod_mbox/incubator-general/201801.mbox/%3CC4C5D5C4-AB44-4AFE-ADE2-9E91F593A9B3%40classsoftware.com%3E]
> and here:
> [http://mail-archives.apache.org/mod_mbox/incubator-general/201801.mbox/%3C157E0E80-9984-4AB5-8AE5-E76C4668D53E%40classsoftware.com%3E]
>  
> That we should check if NetBeans can use "org.eclipse.osgi_3.9.1.v20140110-1610.jar":
> [http://hg.netbeans.org/binaries/E5DDC5E827D3D62E7BE9F7E32927CA01F2839971-org.eclipse.osgi_3.9.1.v20140110-1610.jar]
>  
> My understanding is that the concern here is the license of the file. To quote the relevant
note from the e-mail:
> {code:java}
> platform/modules/ext/org.eclipse.osgi_3.9.1.v20140110-1610.jar 
> - I’m not sure if the OSGi license is compatible with the Apache one. It’s not listed
> in Category A/B/X you may need to ask on legal discuss. It may be under EPL but not 100%
sure.
> {code}
>  
> The license appears to be in an "about.html" file inside the jar. (I can attach it if
desired.)
>  
> Thanks.
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: legal-discuss-unsubscribe@apache.org
For additional commands, e-mail: legal-discuss-help@apache.org


Mime
View raw message