www-legal-discuss mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ate Douma (JIRA)" <j...@apache.org>
Subject [jira] [Created] (LEGAL-279) Apache NetBeans optional Java cluster depending on external GPLv2+CPE nb-javac module
Date Sun, 06 Nov 2016 21:48:00 GMT
Ate Douma created LEGAL-279:
-------------------------------

             Summary: Apache NetBeans optional Java cluster depending on external GPLv2+CPE
nb-javac module
                 Key: LEGAL-279
                 URL: https://issues.apache.org/jira/browse/LEGAL-279
             Project: Legal Discuss
          Issue Type: Question
            Reporter: Ate Douma


The Apache NetBeans incubator project is asking for an answer from the Apache Legal Affairs
Committee to the following question:
{quote}
  Is the Apache NetBeans project allowed to develop and release
  optional "Java cluster" modules which depends on the external category-X  (GPLv2+CPE) licensed
nb-javac module?
NetBeans users who wants to use these optional "Java cluster" modules will be required to
provide for or install the nb-javac module themselves.
{quote}

The proposed solution and the above question, as well as possible alternative solutions, have
been discussed at length \[1] on the project dev@ list, with a latest summary by me at \[2].

The nb-javac module is a NetBeans specific fork of the Java JDK Java compiler, and is explicitly
excluded by Oracle from the NetBeans code donation to Apache.
The NetBeans optional Java cluster modules (for example the Java Editor) have an direct compile
and runtime dependency on the nb-javac module (api and implementation).

While Java is an important optional module for NetBeans, and many NetBeans users do use/need
it for Java development support, it is not part of the NetBeans core.
NetBeans also has many users not using or needing the Java support, for example for C/C++,
Javascript or PHP development, or when using NetBeans as platform for other products.

The proposed solution, requiring end users to install the Category-X nb-javac module themselves,
only if they want to use the NetBeans Java cluster modules, assumes that the Java cluster
modules may be regarded as "optional" as explained at \[3].

\[1] https://lists.apache.org/thread.html/16b99577a9b219e87ff1b1bcd22edd2f2faf105f338d025350126d22@%3Cdev.netbeans.apache.org%3E
\[2] https://lists.apache.org/thread.html/7ebc9ae9d6e5fceced128768f6cf312e837348cc66c3fafde02cd666@%3Cdev.netbeans.apache.org%3E
\[3] http://www.apache.org/legal/resolved.html#optional



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: legal-discuss-unsubscribe@apache.org
For additional commands, e-mail: legal-discuss-help@apache.org


Mime
View raw message