www-legal-discuss mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: Dependency on OpenSSL
Date Fri, 03 Jun 2016 04:17:08 GMT
Interestingly, while we seem to be discussing BSD 4-clause, I discovered
that, according to Wikipedia [1], OpenSSL is under Apache 1.0, not BSD
4-clause, and when comparing OpenSSL's license [2] against this copy of
Apache 1.0 [3], I'd have to agree.

Even more interestingly, Apache 1.0 doesn't seem to be listed in [4] under
Category A, B, or X either.  Is there some past ruling about Apache 1.0?
I would hope Apache 1.0 is ok to use in Apache 2.0 projects.  And if it
is, then it does raise questions about the categorization of the
advertising clause in BSD 4-clause since Apache 1.0 has the same sort of
clause.

Thoughts?
-Alex

[1] https://en.wikipedia.org/wiki/OpenSSL
[2] https://www.openssl.org/source/license.html
[3] https://www.apache.org/licenses/LICENSE-1.0
[4] http://www.apache.org/legal/resolved.html

Mime
View raw message