www-legal-discuss mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Stier <markus.st...@stegmannsystems.com>
Subject Clarify relation between GPL and Apache license
Date Wed, 14 Dec 2011 10:28:48 GMT
Hi!

There are currently (at least) two places which address the compatibility between GPL 2.x
and the Apache license 2.0.
At  http://www.apache.org/foundation/license-faq.html#GPL<http://www.google.com/url?sa=D&q=http://www.apache.org/foundation/license-faq.html%23GPL&usg=AFQjCNH02TOYbzl_XyBrUqHyzHRv1PHsMQ>,
ASF states that both licenses are compatible. This is misleading or even incorrect.

According to http://www.apache.org/licenses/GPL-compatibility.html<http://www.google.com/url?sa=D&q=http://www.apache.org/licenses/GPL-compatibility.html&usg=AFQjCNEBUqUHJUJGs0TrdrzyurFkaPnaMQ>,
the Apache 2.0 license is only compatible to GPL >= 2.x if the GPLed
software uses Apache'd libraries but not vice versa. This seems to be the more appropriate
statement.

I suggest that the FAQ page should be updated.

Best

Markus

Mime
View raw message