www-legal-discuss mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <rick.hille...@oracle.com>
Subject Re: [jira] Created: (LEGAL-89) Can an Apache release have a dependency on classes that are in OpenJDK 7 under GPLv2 with the classpath exception?
Date Tue, 08 Mar 2011 13:23:38 GMT
The title of this issue does not reflect its urgency. The Derby 
community would like to produce a release containing JDBC 4.1 support. 
That release is on hold pending the resolution of this issue. It would 
be a great help to Derby if this issue could be resolved soon.

Thanks,
-Rick

On 3/7/11 11:51 AM, Kathey Marsden (JIRA) wrote:
> Can an Apache release have a dependency on classes that are in OpenJDK 7 under GPLv2
with the classpath exception?
> ------------------------------------------------------------------------------------------------------------------
>
>                   Key: LEGAL-89
>                   URL: https://issues.apache.org/jira/browse/LEGAL-89
>               Project: Legal Discuss
>            Issue Type: Question
>              Reporter: Kathey Marsden
>
>
> The Derby community is  getting ready to cut a release candidate for our 10.8
> release which includes  implementations of JDBC 4.1 methods generally described
> in the document  JDBC-4.1_Changes.html attached to DERBY-4869.
>
> The full specification as I  understand it is in the form of javadoc API
> checked into OpenJDK 7 codeline.  The licensing for  OpenJDK is outlined here:
> http://openjdk.java.net/legal/.
>
> Contrary to previous  JDBC spec releases, there does not seem to be a separate generally
available pdf  describing the changes.  The changes are outlined within the source code in
 javadoc as part of JSR336 Java SE 7 with spec license terms are outlined  in section 2.1.18
at http://www.jcp.org/en/jsr/detail?id=336. Note Derby as implementing a JDBC driver is not
implementing a JSR, only referencing one.
>
> The  Derby code changes associated with DERBY-4869 were contributed by an Oracle  employee
and Derby committer and PMC member Rick Hillegas  and all have the  grant Apache ASL v2 box
marked.     Knut Anders Hatlen (also from  Oracle) looked at the classes in the java.sql and
java.sqlx Classes   and verified that they all are GPL2 with the classpath exception. Is 
there reason for legal concern, license, patent or other with releasing
> Derby  10.8 with JDBC 4.1?
>
>
> --
> This message is automatically generated by JIRA.
> For more information on JIRA, see: http://www.atlassian.com/software/jira
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: legal-discuss-unsubscribe@apache.org
> For additional commands, e-mail: legal-discuss-help@apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: legal-discuss-unsubscribe@apache.org
For additional commands, e-mail: legal-discuss-help@apache.org


Mime
View raw message