www-jcp-open mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geir Magnusson Jr." <g...@pobox.com>
Subject Re: java6 and JAX-WS/JAXB
Date Tue, 15 Jan 2008 10:23:04 GMT
This has been working this way for years, hasn't it?

geir

On Jan 15, 2008, at 11:12 AM, Steve Loughran wrote:

> Geir Magnusson Jr. wrote:
>> yeah, I think it's hard to see a problem - they are updating the  
>> RI, for all practical purposes.  I guess it's arguable that this is  
>> mandating functionality by specifing new versions of the  
>> subordinate JSRs, but I don't think anyone would care unless there  
>> was a valid technical, legal or -ish objection
>> geir
>
> I think its a serious precedent, as it moves the maintenance  
> releases into new features -and guarantees that any jaxb/jax-ws code  
> built on the new version wont even link on java6 < v4, let alone  
> work the same.
>
>> On Jan 14, 2008, at 10:26 AM, Steve Loughran wrote:
>>>
>>> I've just discovered that the new release of java 6, java6.4, has  
>>> just updated its supported API versions of JAX-WS and JAX-B, from  
>>> version 2.0 to 2.1:
>>>
>>> http://weblogs.java.net/blog/ramapulavarthi/archive/2008/01/jaxws_21_and_ja.html
>>>
>>> How does this fit in with the JCP rules?
>>>
>>> -- 
>>> Steve Loughran                  http://www.1060.org/blogxter/publish/5
>>>
>
>
>


Mime
View raw message