www-infrastructure-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geoffrey Corey (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (INFRA-12381) upgrade puppet to current 3.8.7
Date Sat, 06 Aug 2016 00:41:20 GMT

    [ https://issues.apache.org/jira/browse/INFRA-12381?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15410339#comment-15410339
] 

Geoffrey Corey commented on INFRA-12381:
----------------------------------------

https://docs.puppet.com/puppet/3.8/reference/upgrading.html#always-upgrade-the-puppet-master-first

Make sure to upgrade the master first.

> upgrade puppet to current 3.8.7
> -------------------------------
>
>                 Key: INFRA-12381
>                 URL: https://issues.apache.org/jira/browse/INFRA-12381
>             Project: Infrastructure
>          Issue Type: Planned Work
>          Components: Puppet
>            Reporter: Chris Lambertus
>            Assignee: Chris Lambertus
>
> The currently pinned version 3.8.6-1 is deprecated and the package no longer available.
This causes problems upgrading the agents on new systems.
> Upgrading requires the new version 3.8.7 be pinned in the puppet_asf module in master.pp
and init.pp
> The master must be manually upgraded first. The agents can self-upgrade on their scheduled
runs. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message