www-infrastructure-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geoff Macartney (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (INFRA-11392) Request for Golang 1.6 on build servers for Apache Brooklyn brooklyn-client
Date Mon, 14 Mar 2016 09:07:33 GMT

     [ https://issues.apache.org/jira/browse/INFRA-11392?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Geoff Macartney resolved INFRA-11392.
-------------------------------------
    Resolution: Fixed

Resolving per above comment.

> Request for Golang 1.6 on build servers for Apache Brooklyn brooklyn-client 
> ----------------------------------------------------------------------------
>
>                 Key: INFRA-11392
>                 URL: https://issues.apache.org/jira/browse/INFRA-11392
>             Project: Infrastructure
>          Issue Type: New Feature
>          Components: Jenkins
>         Environment: Build servers for Apache Brooklyn.
>            Reporter: Geoff Macartney
>            Assignee: Daniel Takamori
>
> Apache Brooklyn is receiving a code for a new CLI tool [1], at https://github.com/apache/brooklyn-client.
Assuming the vote passes we will need to set up a build process for the tool.  This requires
Go 1.6 with cross compiler support.  We haven’t merged the pr that needs this yet but from
looking at https://github.com/apache/infrastructure-puppet/ it appears Jenkins is using standard
trusty golang packages which are Go 1.2.
> This is a request to start the process to install Go 1.6 on appropriate Jenkins build
servers.
> I have successfully built the CLI tool once Go was installed following the process below
on a fresh Ubuntu Trusty:
> 1. Remove any existing Golang packages.
> 2. To get Go 1.6 I followed the instructions on the page [2] and link to [3], and added
the following to /etc/apt/sources.list:
> deb http://ppa.launchpad.net/ubuntu-lxc/lxd-stable/ubuntu trusty main
> deb-src http://ppa.launchpad.net/ubuntu-lxc/lxd-stable/ubuntu trusty main
> 3. apt-get update
> 4. apt-get install golang
> (I also had to install git and maven)
> This allowed me to build the code once I had fetched it from Github. (Noting here for
completeness that we need cross compiler support, but the above  process allowed the build
to succeed even without explicitly installing the cross-compiler packages golang-go-*-{386,amd64,arm},
to my surprise.)
> Apologies in advance if I've misread the manifest and this is all already available,
or if I'm not following the right process here, I'm kinda new to this.
> [1] http://mail-archives.apache.org/mod_mbox/incubator-general/201602.mbox/%3cCABQFKi1-VxhduAnn0BKewsDihWJP0kcBZ5KerWi=VXVjs-+5bQ@mail.gmail.com%3e
> [2] https://github.com/golang/go/wiki/Ubuntu
> [3] https://launchpad.net/%7Eubuntu-lxc/+archive/ubuntu/lxd-stable



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message