www-infrastructure-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Lambertus (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (INFRA-11113) Errors deploying Maven artifacts from Lucene Jenkins jobs to the Nexus snapshot repository
Date Sat, 05 Mar 2016 06:54:40 GMT

     [ https://issues.apache.org/jira/browse/INFRA-11113?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chris Lambertus resolved INFRA-11113.
-------------------------------------
    Resolution: Unresolved

Steve, I agree that it's discouraging, and I really apologize, for whatever that's worth.
We don't have a lot of internal Infra knowledge for Nexus, and that's something we're trying
to fix. We're working on improving our response to tickets too, so things like this don't
end up missed. 

If I had to throw out a guess, I'd say this is probably related to the size of the artifact.
Please submit a new issue if it happens again. 

> Errors deploying Maven artifacts from Lucene Jenkins jobs to the Nexus snapshot repository
> ------------------------------------------------------------------------------------------
>
>                 Key: INFRA-11113
>                 URL: https://issues.apache.org/jira/browse/INFRA-11113
>             Project: Infrastructure
>          Issue Type: Bug
>          Components: Jenkins, Nexus
>            Reporter: Steve Rowe
>         Attachments: jenkins-maven-nightly.output.1.txt, jenkins-maven-nightly.output.2.txt,
jenkins-maven-nightly.output.3.txt, jenkins-maven-nightly.output.4.txt, jenkins-maven-nightly.output.5.txt,
jenkins-maven-nightly.output.6.txt, jenkins-maven-nightly.output.7.txt
>
>
> The Lucene project has been having trouble deploying Maven artifact snapshots to ASF
Nexus from Jenkins jobs since about January 13th.
> Jenkins jobs use Lucene's Ant build to generate Maven artifacts for each of about 40
sub-modules, then deploy them to the Nexus snapshot repo, one session per module, using Maven
Ant Tasks's artifact:deploy task.
> Sometimes some artifacts successfully deploy, but none of the 4 nightly Jenkins jobs
(one per dev branch) has fully succeeded in the last 10 days.
> Mostly the reported errors are connection timeouts, but we're getting a couple of other
errors: in one case, a 401 return code; and in several cases, "SSL peer shut down incorrectly".
> Previously, we would see occasional failures (like once a month per job or something),
but this is radically different: no success in 10 days.
> Here's an example for each of the different errors:
> ----- 
> https://builds.apache.org/job/Lucene-Solr-Maven-trunk/1662/consoleText
> -----
> [artifact:deploy] [INFO] Retrieving previous build number from apache.snapshots.https
> [artifact:deploy] An error has occurred while processing the Maven artifact tasks.
> [artifact:deploy]  Diagnosis:
> [artifact:deploy] 
> [artifact:deploy] Error deploying artifact 'org.apache.lucene:lucene-solr-grandparent:pom':
Error retrieving previous build number for artifact 'org.apache.lucene:lucene-solr-grandparent:pom':
repository metadata for: 'snapshot org.apache.lucene:lucene-solr-grandparent:6.0.0-SNAPSHOT'
could not be retrieved from repository: apache.snapshots.https due to an error: Error transferring
file: Remote host closed connection during handshake
> [artifact:deploy] SSL peer shut down incorrectly
> ----- 
> https://builds.apache.org/job/Lucene-Solr-Maven-trunk/1661/consoleText
> -----
> [artifact:deploy] Uploading: org/apache/lucene/lucene-test-framework/6.0.0-SNAPSHOT/lucene-test-framework-6.0.0-20160120.053514-434.jar
to repository apache.snapshots.https at https://repository.apache.org/content/repositories/snapshots
> [artifact:deploy] Transferring 6373K from apache.snapshots.https
> [artifact:deploy] Uploaded 6373K
> [artifact:deploy] [INFO] Retrieving previous metadata from apache.snapshots.https
> [artifact:deploy] [INFO] Uploading repository metadata for: 'snapshot org.apache.lucene:lucene-test-framework:6.0.0-SNAPSHOT'
> [artifact:deploy] [INFO] Retrieving previous metadata from apache.snapshots.https
> [artifact:deploy] [INFO] Uploading repository metadata for: 'artifact org.apache.lucene:lucene-test-framework'
> [artifact:deploy] [INFO] Uploading project information for lucene-test-framework 6.0.0-20160120.053514-434
> [artifact:deploy] [INFO] Retrieving previous build number from apache.snapshots.https
> [artifact:deploy] An error has occurred while processing the Maven artifact tasks.
> [artifact:deploy]  Diagnosis:
> [artifact:deploy] 
> [artifact:deploy] Error deploying artifact 'org.apache.lucene:lucene-test-framework:jar':
Error retrieving previous build number for artifact 'org.apache.lucene:lucene-test-framework:jar:sources':
repository metadata for: 'snapshot org.apache.lucene:lucene-test-framework:6.0.0-SNAPSHOT'
could not be retrieved from repository: apache.snapshots.https due to an error: Error transferring
file: Connection timed out
> -----
> https://builds.apache.org/job/Lucene-Solr-Maven-5.x/1158/consoleText
> -----
> [artifact:deploy] Uploading: org/apache/lucene/lucene-parent/5.5.0-SNAPSHOT/lucene-parent-5.5.0-20160113.082837-43.pom
to repository apache.snapshots.https at https://repository.apache.org/content/repositories/snapshots
> [artifact:deploy] Transferring 5K from apache.snapshots.https
> [artifact:deploy] An error has occurred while processing the Maven artifact tasks.
> [artifact:deploy]  Diagnosis:
> [artifact:deploy] 
> [artifact:deploy] Error deploying artifact 'org.apache.lucene:lucene-parent:pom': Error
deploying artifact: Failed to transfer file: https://repository.apache.org/content/repositories/snapshots/org/apache/lucene/lucene-parent/5.5.0-SNAPSHOT/lucene-parent-5.5.0-20160113.082837-43.pom.
Return code is: 401
>  



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message