www-infrastructure-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Shahaf (äñ§€¥£¢) (JIRA) <j...@apache.org>
Subject [jira] [Commented] (INFRA-10857) Password resets not reflected by svn-us.apache.org
Date Tue, 15 Mar 2016 01:35:33 GMT

    [ https://issues.apache.org/jira/browse/INFRA-10857?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15194531#comment-15194531
] 

Daniel Shahaf (äñ§€¥£¢) commented on INFRA-10857:
-------------------------------------------------

My password resets should up on lastlog on minotaur as 00:00-long sessions.  (This indicator
should be almost 100% sensitive and specific: I always reset my password using the same 'ssh
-t'-based script, and I never 'ssh -t' to minotaur otherwise.)

I see password resets on Mar 14 at 00:34 and 00:37.  I tried within 10 minutes of those resets
and my password was rejected.

I then see a failed commit attempt at 00:58.  So, that makes it 21 minutes, from 00:37 to
00:58: that's just about what I remembered, and the logs concur.

The logs also show a bunch of commit attempts and a password reset at 01:07, but I'm not sure
which of these two preceded the other.

Today, I reset my password some time ago to send an email (at Mar 14 23:51/23:54), and later,
when I saw your jira comment, I reset my password again (Mar 15 00:44) and immediately tried
an 'svn info' against /private/committers, which succeeded.  (So yesterday it was a commit
to /repos/asf, and today an 'svn info' to /repos/private.)

Over the course of months... Hard to say.  It was never perfectly reproducible.  At some point
I picked up the habit of resetting my password as soon as I login to my workstation (so when
I later during the day need to commit, the magic will have already happened), so I was less
liable to notice the issue even if it were still present.

I was never able to reproduce the problem against mail-relay.a.o: it always instantly accepted
the new password.

> Password resets not reflected by svn-us.apache.org
> --------------------------------------------------
>
>                 Key: INFRA-10857
>                 URL: https://issues.apache.org/jira/browse/INFRA-10857
>             Project: Infrastructure
>          Issue Type: Bug
>          Components: LDAP, Subversion
>            Reporter: Daniel Shahaf (äñ§€¥£¢)
>            Assignee: Chris Lambertus
>
> After changing my password using {{ssh -t minotaur.apache.org sudo passwd danielsh}},
svn-eu.apache.org accepts my new password immediately but svn-us.apache.org does not.  I test
with {{svn info https://svn-us.apache.org/repos/private/committers}}.
> This has been preventing me from making commits.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message