www-infrastructure-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gavin (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (INFRA-10290) Oozie precommit build jenkins job not running due to 'xpath: command not found'
Date Wed, 06 Jan 2016 23:26:39 GMT

     [ https://issues.apache.org/jira/browse/INFRA-10290?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Gavin updated INFRA-10290:
--------------------------
    Fix Version/s: Sep 2015

> Oozie precommit build jenkins job not running due to 'xpath: command not found'
> -------------------------------------------------------------------------------
>
>                 Key: INFRA-10290
>                 URL: https://issues.apache.org/jira/browse/INFRA-10290
>             Project: Infrastructure
>          Issue Type: Bug
>          Components: Jenkins
>            Reporter: Mona Chitnis
>            Assignee: Andrew Bayer
>             Fix For: Sep 2015
>
>
> I'm an Oozie PMC member and our precommit build jenkins job (https://builds.apache.org/job/oozie-trunk-precommit-build/)
is not running since past 3 days due to the parent job (https://builds.apache.org/job/oozie-trunk-find-patches-available/)
facing following error as seen from Console log:
> {{./test-patch-find-new-patch-available-jiras: line 78: xpath: command not found}}
> https://builds.apache.org/job/oozie-trunk-find-patches-available/67807/console
> The command from the script is
> {{xpath -q -e "//item/key/text() | //item/attachments/attachment[not(../attachment/@id
> @id)]/@id" ${TEMPDIR}/patch-availables.xml > ${TEMPDIR}/patch-attachments.element}}
> Can you please help restore 'xpath' to be found in the path on these machines - https://builds.apache.org/label/Hadoop/
?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message