www-infrastructure-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geoffrey Corey (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (INFRA-10250) Unable to deploy repository.apache.org as committer for Apache Turbine
Date Thu, 03 Sep 2015 22:43:46 GMT

    [ https://issues.apache.org/jira/browse/INFRA-10250?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14729954#comment-14729954
] 

Geoffrey Corey commented on INFRA-10250:
----------------------------------------

Are you sure the creds are entered correctly? Also, (just learned this yesterday) but is the
password in settings.xml encrypted or in plain text?

> Unable to deploy repository.apache.org as committer for Apache Turbine
> ----------------------------------------------------------------------
>
>                 Key: INFRA-10250
>                 URL: https://issues.apache.org/jira/browse/INFRA-10250
>             Project: Infrastructure
>          Issue Type: Task
>          Components: Nexus
>            Reporter: Siegfried Goeschl
>            Priority: Minor
>         Attachments: nexus.png
>
>
> Hi folks,
> after a long break I try to release an Apache Turbine component and I got stuck uploading
to repository.apache.org.
> * Apache User Name : sgoeschl
> * I can login to people.apache.org
> * I can login to https://id.apache.org
> ** I have two public keys stored there
> * I'm Apache Turbine PMC (http://people.apache.org/committers-by-project.html#turbine-pmc)
> When I try to release I finally got the following error message
> {noformat}
> Uploading: https://repository.apache.org/content/repositories/snapshots/org/apache/turbine/fulcrum-yaafi/1.0.7-SNAPSHOT/fulcrum-yaafi-1.0.7-20150814.174321-2.pom
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:2.7:deploy
(default-deploy) on project fulcrum-yaafi: Failed to deploy artifacts: Could not transfer
artifact org.apache.turbine:fulcrum-yaafi:jar:1.0.7-20150814.174321-2 from/to apache.snapshots.https
(https://repository.apache.org/content/repositories/snapshots): Failed to transfer file: https://repository.apache.org/content/repositories/snapshots/org/apache/turbine/fulcrum-yaafi/1.0.7-SNAPSHOT/fulcrum-yaafi-1.0.7-20150814.174321-2.jar.
Return code is: 401, ReasonPhrase: Unauthorized. -> [Help 1]
> {noformat}
> Trying to log on to repository.apache.org
> {noformat}
> > ssh -v repository.apache.org
> OpenSSH_6.2p2, OSSLShim 0.9.8r 8 Dec 2011
> debug1: Reading configuration data /Users/sgoeschl/.ssh/config
> debug1: /Users/sgoeschl/.ssh/config line 12: Applying options for repository.apache.org
> debug1: Reading configuration data /etc/ssh_config
> debug1: /etc/ssh_config line 20: Applying options for *
> debug1: Connecting to repository.apache.org [140.211.11.112] port 22.
> debug1: Connection established.
> debug1: identity file /Users/sgoeschl/.ssh/sgoeschl@gmx.at type 1
> debug1: identity file /Users/sgoeschl/.ssh/sgoeschl@gmx.at-cert type -1
> debug1: Enabling compatibility mode for protocol 2.0
> debug1: Local version string SSH-2.0-OpenSSH_6.2
> debug1: Remote protocol version 2.0, remote software version OpenSSH_6.6.1p1 Ubuntu-2ubuntu2
> debug1: match: OpenSSH_6.6.1p1 Ubuntu-2ubuntu2 pat OpenSSH*
> debug1: SSH2_MSG_KEXINIT sent
> debug1: SSH2_MSG_KEXINIT received
> debug1: kex: server->client aes128-ctr hmac-md5-etm@openssh.com none
> debug1: kex: client->server aes128-ctr hmac-md5-etm@openssh.com none
> debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
> debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
> debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
> debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
> debug1: Server host key: RSA cc:4f:5c:fe:f2:a0:a7:c7:8b:92:de:4c:95:23:4d:21
> debug1: Host 'repository.apache.org' is known and matches the RSA host key.
> debug1: Found key in /Users/sgoeschl/.ssh/known_hosts:62
> debug1: ssh_rsa_verify: signature correct
> debug1: SSH2_MSG_NEWKEYS sent
> debug1: expecting SSH2_MSG_NEWKEYS
> debug1: SSH2_MSG_NEWKEYS received
> debug1: Roaming not allowed by server
> debug1: SSH2_MSG_SERVICE_REQUEST sent
> debug1: SSH2_MSG_SERVICE_ACCEPT received
> debug1: Authentications that can continue: publickey
> debug1: Next authentication method: publickey
> debug1: Offering RSA public key: /Users/sgoeschl/.ssh/sgoeschl@gmx.at
> debug1: Server accepts key: pkalg ssh-rsa blen 277
> LDAP authorisation check failed
> Connection closed by 140.211.11.112
> {noformat}
> So it seems somehow related to "LDAP authorisation check failed"
> Any ideas?
> Thanks in advance
> Siegfried Goeschl



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message