www-infrastructure-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Udo Schnurpfeil (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (INFRA-9743) Jenkins build with Java 1.5 not possible
Date Mon, 01 Jun 2015 07:37:17 GMT

    [ https://issues.apache.org/jira/browse/INFRA-9743?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14567022#comment-14567022
] 

Udo Schnurpfeil commented on INFRA-9743:
----------------------------------------

In that case I suggest to remove all JDKs from the list which is older than 1.6

here is the List, it contains many 1.4 and 1.5 versions

* JDK 1.4 (latest)
* JDK 1.5 (latest)
* JDK 1.6 (latest)
* IBM 1.4 32-bit (on Ubuntu only)
* IBM 1.4 64-bit (on Ubuntu only)
* IBM 1.5 32-bit (on Ubuntu only)
* IBM 1.5 64-bit (on Ubuntu only)
* IBM 1.6 32-bit (on Ubuntu only)
* IBM 1.6 64-bit (on Ubuntu only)
* Harmony 1.5 64-bit (on Ubuntu only) 
* Harmony 1.5 32-bit (on Ubuntu only) 
* JDK 1.6 (unlimited security)
* JDK 1.7 (latest)
* Oracle JDK 1.7 for ARM based. DO NOT USE unless on one of the ARM slaves, you can also choose
'Default'
* OpenJDK 6 (on Ubuntu only) 
* OpenJDK 7 (on Ubuntu only) 
* JDK 1.5 (Latest 64 bit on Windows only)
* JDK 1.5 (Latest 32 bit on Windows only)
* IBM 1.7 64-bit (on Ubuntu only)
* jdk-1.7u45
* Open JDK 1.8 (Only on ubuntu nodes)
* jdk-1.7u51
* jdk-1.6u45
* jdk-1.7u51
* jdk-1.8.0
* JAVA_HOME_HADOOP_MACHINES
* jdk1.8.0_05
* jdk1.8.0_11
* latest1.6
* latest1.7
* latest1.8
* jdk-1.7.0_79 (unlimited security)




> Jenkins build with Java 1.5 not possible
> ----------------------------------------
>
>                 Key: INFRA-9743
>                 URL: https://issues.apache.org/jira/browse/INFRA-9743
>             Project: Infrastructure
>          Issue Type: Bug
>          Components: Jenkins
>            Reporter: Udo Schnurpfeil
>            Assignee: Andrew Bayer
>
> Using JDK 1.5 failed, because a part of Jenkins seems to be compiled for JDK 1.6
> [tobago-1.0.x] $ /home/jenkins/tools/java/ibm-1.5-32/bin/java -Xmx2g -Xms256m -XX:MaxPermSize=512m
-cp /home/jenkins/jenkins-slave/maven-agent.jar:/home/jenkins/jenkins-slave/classworlds.jar
hudson.maven.agent.Main /home/jenkins/tools/maven/apache-maven-2.2.1 /home/jenkins/jenkins-slave/slave.jar
/home/jenkins/jenkins-slave/maven-interceptor.jar 38984 /home/jenkins/jenkins-slave/maven2.1-interceptor.jar
> Exception in thread "main" java.lang.UnsupportedClassVersionError: (hudson/remoting/Launcher)
bad major version at offset=6
> 	at java.lang.ClassLoader.defineClassImpl(Native Method)
> ...
> There might be a workaround: https://issues.jenkins-ci.org/browse/JENKINS-25272



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message