www-infrastructure-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geoffrey Corey (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (INFRA-9605) Unable to clone Git repo on git-wip-us
Date Mon, 18 May 2015 22:05:01 GMT

    [ https://issues.apache.org/jira/browse/INFRA-9605?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14549327#comment-14549327
] 

Geoffrey Corey edited comment on INFRA-9605 at 5/18/15 10:04 PM:
-----------------------------------------------------------------

Ok, I think I'm on to something.

I have a test vm + test url setup using the same wildcard cert as used on git-wip-us.apache.org.

Can you try (from within git bash):
curl -v https://git-wip-us.apache.org > index.html

In my windows environment, it is not outputting anything about ssl verification issues (but
still does for https://git-wip-us.apache.org).

If I can verify that it was indeed a chain issue, then I can get the updated chain into configuration
management.


was (Author: coreyg):
Ok, I think I'm on to something.

I have a test vm + test url setup using the same wildcard cert as used on git-wip-us.apache.org.

Can you try (from within git bash):
curl -v https://git-wip-us.apache.org > index.html

In my windows environment, it is not outputting anything about ssl verification issues.

If I can verify that it was indeed a chain issue, then I can get the updated chain into configuration
management.

> Unable to clone Git repo on git-wip-us
> --------------------------------------
>
>                 Key: INFRA-9605
>                 URL: https://issues.apache.org/jira/browse/INFRA-9605
>             Project: Infrastructure
>          Issue Type: Bug
>          Components: Git
>         Environment: Windows 7 Professional, Service Pack 1
> 64 bit
> Git Bash + Tortoise Git
>            Reporter: OmPrakash Muppirala
>            Assignee: Geoffrey Corey
>         Attachments: ViewSiteInformation_Chrome_Windows.png, curl-7.42.1-win32.7z
>
>
> Steps to reproduce:
> Run
> git.exe clone --progress -v "https://git-wip-us.apache.org/repos/asf/flex-utilities.git"
"C:\p\flexroot\git\flex-utilities"
> Expected result:
> Should be able to clone repo successfully
> Actual result:
> Cloning into 'C:\p\flexroot\git\flex-utilities'...
> fatal: unable to access 'https://git-wip-us.apache.org/repos/asf/flex-utilities.git/':
SSL certificate problem: unable to get local issuer certificate
> git did not exit cleanly (exit code 128) (468 ms @ 5/5/2015 3:48:47 PM)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message