www-infrastructure-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geoffrey Corey (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (INFRA-9603) Unable to validate SSL cert on https://git-wip-us.apache.org
Date Tue, 05 May 2015 21:21:00 GMT

    [ https://issues.apache.org/jira/browse/INFRA-9603?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14529305#comment-14529305
] 

Geoffrey Corey commented on INFRA-9603:
---------------------------------------

Infra has moved off IRC to hipchat for better availability interaction and logging. You can
join us at https://s.apache.org/infrachat

As for the SSL problem you are reporting, it is that either the git binary or openssl isn't
finding the correct CA certificate on your computer.

I am going to be getting a windows environment setup to see if I can figure out what is going
on, as it works find in Linux, using git, firefox, or chrome.

> Unable to validate SSL cert on https://git-wip-us.apache.org
> ------------------------------------------------------------
>
>                 Key: INFRA-9603
>                 URL: https://issues.apache.org/jira/browse/INFRA-9603
>             Project: Infrastructure
>          Issue Type: Bug
>            Reporter: Owen O'Malley
>
> I'm using git on a Mac:
> {noformat}
> % git --version
> git version 2.4.0
> {noformat}
> I'm able to access https urls on git.apache.org and github.com, but when I access https://git-wip-us.apache.org
it fails unless I set sslVerify = false in my git config.
> {noformat}
> % git fetch apache
> fatal: unable to access 'https://git-wip-us.apache.org/repos/asf/orc.git/': SSL certificate
problem: unable to get local issuer certificate
> {noformat}
> It happens with both of the repositories I tried hive.git and orc.git.
> I tried to join #asfinfra on freenode as owen_omalley, but it is blocked. :(



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message