www-infrastructure-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl Heinz Marbaise (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (INFRA-9175) Updating maven.apache.org site download.cgi with an executable flag does not work
Date Wed, 18 Feb 2015 19:23:11 GMT

    [ https://issues.apache.org/jira/browse/INFRA-9175?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14326415#comment-14326415
] 

Karl Heinz Marbaise edited comment on INFRA-9175 at 2/18/15 7:22 PM:
---------------------------------------------------------------------

I have taken a look into the [perl code|https://svn.apache.org/repos/infra/websites/cms/]
the following lines gave me a good hint:
in {{build/lib/ASF/SVNUtil.pm}}:
{code}
    # ignores property mods, etc.; turns out we don't need them for our use-case
    /^([MAD?!CIRX~]).{7}(.+)$/ and push @{$rv{$st_dispatch{$1}}}, $2 for @status;
{code}



was (Author: khmarbaise):
I have taken a look into the [perl code|https://svn.apache.org/repos/infra/websites/cms/]
the following lines gave me a good hint:
in {{build/lib/ASF/SVNUtil.pm}}:
{code:perl}
    # ignores property mods, etc.; turns out we don't need them for our use-case
    /^([MAD?!CIRX~]).{7}(.+)$/ and push @{$rv{$st_dispatch{$1}}}, $2 for @status;
{code}


> Updating maven.apache.org site download.cgi with an executable flag does not work
> ---------------------------------------------------------------------------------
>
>                 Key: INFRA-9175
>                 URL: https://issues.apache.org/jira/browse/INFRA-9175
>             Project: Infrastructure
>          Issue Type: Bug
>          Components: Buildbot, SvnPubSub, Website
>            Reporter: Karl Heinz Marbaise
>
> I have changed the svn:executable flag in the https://svn.apache.org/repos/asf/maven/site/trunk
but unfortunately the flag is not transfered to the production site.
> In the stdiou output of the triggered build http://ci.apache.org/builders/maven-site-staging/builds/231/steps/shell/logs/stdio
you can't see that the download.cgi file has been updated, cause it contains only a change
in the above property.
> The result is that on production site / staging site the download.cgi does not have executable
permission which results in server error.
> Currently the work-a-round is to manually fix the property on production svn https://svn.apache.org/repos/infra/websites/production/maven/content...
> But the permission goes lost through the process of creation.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message