www-infrastructure-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gavin (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (INFRA-8278) Update Log4j 2 Buildbot config for site generation
Date Mon, 15 Sep 2014 09:06:34 GMT

     [ https://issues.apache.org/jira/browse/INFRA-8278?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Gavin reassigned INFRA-8278:
----------------------------

    Assignee: Gavin

> Update Log4j 2 Buildbot config for site generation
> --------------------------------------------------
>
>                 Key: INFRA-8278
>                 URL: https://issues.apache.org/jira/browse/INFRA-8278
>             Project: Infrastructure
>          Issue Type: Bug
>          Components: Buildbot
>            Reporter: Matt Sicker
>            Assignee: Gavin
>
> After running {{mvn site}}, the site needs to be run through {{mvn site:stage-deploy
-DstagingSiteURL=file:///tmp/log4j2}} or somewhere similar. Then that can be copied over.
Otherwise, our site is fragmented across the various submodules and don't get merged in the
build process.
> See [this compile step|http://ci.apache.org/builders/log4j2-nightly/builds/100/steps/compile_1]
for what I'm talking about. There's an upload task that comes after which I don't know what
it's doing as there is no stdio log. It may be possible to just use {{-DstagingSiteURL=scp:///etc...}}
in that process to really make things work more easily. Whichever method works best for you
guys.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message