www-infrastructure-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett Porter (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (INFRA-6717) Windows1: Installing VS 2010 or 2012?
Date Tue, 15 Jul 2014 06:58:05 GMT

    [ https://issues.apache.org/jira/browse/INFRA-6717?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14061774#comment-14061774
] 

Brett Porter commented on INFRA-6717:
-------------------------------------

The Windows SDK contains the C compiler (which is installed on windows1 - equivalent to VS
2010), however that seems to have stopped in the latest SDK, and it now requires Visual Studio
2013 again.

C99 requires Visual Studio 2013, as it wasn't supported in VS 2012.

I had a look at doing this, but I'm not sure whether infra prefers to install a full VS 2013,
or VS 2013 Express. I'll try and check later.


> Windows1: Installing VS 2010 or 2012?
> -------------------------------------
>
>                 Key: INFRA-6717
>                 URL: https://issues.apache.org/jira/browse/INFRA-6717
>             Project: Infrastructure
>          Issue Type: New Feature
>          Components: Jenkins
>            Reporter: Martin Veith
>
> At the moment Visual Studio 2008 is installed on windows1 jenkins slave.
> Is it possible to install a newer version of VS like 2010 or 2012?
> Our issue at the moment is that our build relies on a C99 compiler, but Visual Studio
2008 isn't C99 compatible.
> We could do a workaround, but IMO it would be good to have a state of the art VS on one
of our Apache build slaves.
> Thank you very much!



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message