www-infrastructure-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Nalley (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (INFRA-6633) consider update to Clojure 1.5.1 as minimum version
Date Mon, 05 Aug 2013 12:57:49 GMT

     [ https://issues.apache.org/jira/browse/INFRA-6633?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

David Nalley closed INFRA-6633.
-------------------------------

    Resolution: Invalid

Refiled as JCLOUDS-228
                
> consider update to Clojure 1.5.1 as minimum version
> ---------------------------------------------------
>
>                 Key: INFRA-6633
>                 URL: https://issues.apache.org/jira/browse/INFRA-6633
>             Project: Infrastructure
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>            Reporter: Trevor Wennblom
>            Priority: Minor
>
> Currently `core.incubator` is required as a Clojure dependency. The `-?>` function
is available in Clojure 1.5.1 as `some->`.
> * https://github.com/clojure/core.incubator/blob/master/src/main/clojure/clojure/core/incubator.clj#L29
> * https://github.com/clojure/clojure/blob/master/changes.md#24-new-threading-macros
> ```
> % ack "\-\?>"
> apis/ec2/src/main/clojure/org/jclouds/ec2/ebs2.clj
> 22:  (:use org.jclouds.compute2 [clojure.core.incubator :only (-?>)])
> 229:        size (-?> (get-string options :size) as-int)
> compute/src/main/clojure/org/jclouds/compute2.clj
> 62:    (org.jclouds predicate) [clojure.core.incubator :only (-?>)])
> 308:  (-?> node .getLocation .getId))
> ```
> I can put in a pull request for the updates if requiring the newer version of Clojure
is acceptable.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message